3

Every time I try to upgrade it shows me this message

sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libreoffice-avmedia-backend-gstreamer : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-base : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-base-core : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-base-drivers : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-calc : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-draw : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-gnome : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-gtk3 : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-impress : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-math : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-ogltrans : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-sdbc-hsqldb : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 libreoffice-writer : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
 openjdk-11-jre : Depends: openjdk-11-jre-headless (= 11.0.4+11-1ubuntu2~18.04.3) but 10.0.2+13-1ubuntu0.18.04.4 is installed
 python3-uno : Depends: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.9) but 1:6.0.6-0ubuntu0.18.04.1 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
1
  • Did you run sudo apt --fix-broken install? – ajgringo619 Aug 26 '19 at 23:07
2

Try these out:

sudo apt --fix-broken install
sudo apt-get update
sudo apt-get upgrade
3
  • 1
    I tried the first one many times but it seems is not working properly, i get this all the time – Carlos tmf Aug 27 '19 at 17:01
  • 1
    it wont let me use sudo apt --fix-broken install – Carlos tmf Aug 27 '19 at 17:50
  • You can try deleting the lock files if present. sudo rm /var/lib/apt/lists/lock You may also need to delete the lock file in the cache directory sudo rm /var/cache/apt/archives/lock – Anket Padwalkar Aug 28 '19 at 5:49
2
sudo apt --fix-broken install

Is not valid command for apt v.1.6.12. What should help is:

sudo apt install --fix-broken

or

sudo apt reinstall
1
  • Given that apt itself suggests apt --fix-broken install, I think it’s safe to assume that variant works. apt reinstall won’t work on its own, it needs to be told what package to reinstall. – Stephen Kitt Jun 11 '20 at 13:52
0

In certain cases you might also want to force the overwrite

sudo dpkg --configure --force-overwrite -a

Alternatively:

sudo apt -o Dpkg::Options::="--force-overwrite" --fix-broken install

Not the answer you're looking for? Browse other questions tagged or ask your own question.