0

I am trying to install a VPN client (sentinel dVPN) on Linux Mint 18.2 with the .deb

The package manager returns:

"Error: Dependency is not satisfiable: shadowsocks-libev"
sudo apt-get install shadowsocks-libev

returned

E: Unable to locate package shadowsocks-libev"

-

sudo snap install shadowsocks-libev

worked, but the dependency error is still there.

That's the first dependency I installed with snap, so maybe it has problems recognizing them when installed that way?

How can I find out where the problem is?

So far I didn't find a solution, but I am down to one unmet dependency, see: edit2

edit: seems like I hit the next wall of unmet dependencies running

sudo sh -c 'printf "deb http://deb.debian.org/debian stretch-backports main" > /etc/apt/sources.list.d/stretch-backports.list' sudo apt update

returns

Ign:1 http://deb.debian.org/debian stretch-backports InRelease
Get:11 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]
Fetched 417 kB in 3s (124 kB/s)
Reading package lists... Done W: GPG error: http://deb.debian.org/debian stretch-backports InRelease: The >following signatures couldn't be verified because the public key is not available: NO_PUBKEY 7638D0442B90D010 NO_PUBKEY 04EE7237B7D453EC W: The repository 'http://deb.debian.org/debian stretch-backports InRelease' is not signed. N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use. N: See apt-secure(8) manpage for repository creation and user configuration details.

sudo apt -t stretch-backports install shadowsocks-libev

just returns a list of apt commands

sudo apt-get install shadowsocks-libev

now return

Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: shadowsocks-libev :

Depends: libc-ares2 (>= 1.11.0~rc1) but 1.10.0-3ubuntu0.2 is to be installed

Depends: libcork16 but it is not installable

Depends: libcorkipset1 but it is not installable

E: Unable to correct problems, you have held broken packages.

libc-ares2 is installable, but for the other two, it can't find a source

Reading state information... Done Package libcorkipset1 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'libcorkipset1' has no installation candidate

edit2: found and installed the sources for libcork16 and libcorkipset1, but its still stuck on

The following packages have unmet dependencies: shadowsocks-libev : Depends: libc-ares2 (>= 1.11.0~rc1) but 1.10.0-3ubuntu0.2 is to be installed E: Unable to correct problems, you have held broken packages.

I have the installed libc-ares21.10.0-3ubuntu0.2 but it doesn't recognize it... if I fix this one, it should probably work

Any ideas?

0

Mint is debian 9 based so you can install the necessary packages with

sudo sh -c 'printf "deb http://deb.debian.org/debian stretch-backports main" > /etc/apt/sources.list.d/stretch-backports.list'
sudo apt update
sudo apt -t stretch-backports install shadowsocks-libev

https://github.com/shadowsocks/shadowsocks-libev

Snap installs won't solve the apt dependency problems you need to install with apt

  • ok, so I need to get it to run over apt... sudo apt -t stretch-backports install shadowsocks-libev just returns "Usage: apt command [options] apt help command [options] [...] " – ArthasMethenil Aug 24 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.