1

I cannot switch KDE layouts anymore. Despite having two layouts correctly configured in System Settings, I hope, please see the screenshot below, and layout indicator in tray clearly showing CZ flag, my keyboard is still UK English only. Whatever the indicator shows I have UK English only.

enter image description here

Any idea where I should investigate further?

I never had this problem in KDE and I use 2 keyboard layouts in most of my setups for years.

I have strong suspicion that it may have been caused by conflict with IBus, Gnome's input method framework; issue I was reporting here recently: KDE: how to get rid of IBus keyboard selector

I had various issues with IBus and KDE and they are quite known not to play nicely together. Why even openSuse installed them for me!? I played with iBus configuration, mainly to get around issue with suddenly appearing US keyboard. I notably selected for IBus to follow global system settings. That likely fixed my issue with the US keyboard but I am afraid that might be when IBus messed something in my general KDE/X11/system config too. Any ideas where and what? I uninstalled IBus successfully, seemingly, but I cannot switch keyboard layout.

When I installed my openSuse it definitively worked. And I am quite convinced it still worked even after I added Gnome desktop to my KDE desktop.

OS: openSuse 15.0 Linux, KDE (mainly) but with Gnome/Gtk also installed (it's a must).

| improve this question | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.