0

So I've installed Ubuntu 18.04.03 with legacy support because I was having problems while UEFI was enabled. Now I can't get the WiFi nor the touchpad to work. I've updated the Kernel to the most current version and still no luck. Anyone have any ideas as to how I can troubleshoot this? I've gone through three or four different threads trying their approaches and I've had no luck so far.

xinput : ⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PixArt Dell MS116 USB Optical Mouse id=9 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Integrated Camera: Integrated C id=10 [slave keyboard (3)]
↳ Ideapad extra buttons id=11 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]

sudo dmesg -xt | grep -ai input : kern :info : input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0
kern :info : input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input1
kern :info : input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
kern :info : input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input3
kern :info : input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:08/LNXVIDEO:00/input/input4
kern :info : input: PixArt Dell MS116 USB Optical Mouse as /devices/pci0000:00/0000:00:08.1/0000:03:00.3/usb1/1-3/1-3:1.0/0003:413C:301A.0001/input/input5
kern :info : hid-generic 0003:413C:301A.0001: input,hidraw0: USB HID v1.11 Mouse [PixArt Dell MS116 USB Optical Mouse] on usb-0000:03:00.3-3/input0
kern :info : input: Ideapad extra buttons as /devices/pci0000:00/0000:00:14.3/PNP0C09:00/VPC2004:00/input/input6
kern :info : input: Integrated Camera: Integrated C as /devices/pci0000:00/0000:00:08.1/0000:03:00.4/usb3/3-1/3-1:1.0/input/input7
kern :info : input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:08.1/0000:03:00.1/sound/card0/input8
kern :info : snd_hda_codec_realtek hdaudioC1D0: inputs:
kern :info : input: HD-Audio Generic Mic as /devices/pci0000:00/0000:00:08.1/0000:03:00.6/sound/card1/input9
kern :info : input: HD-Audio Generic Headphone as /devices/pci0000:00/0000:00:08.1/0000:03:00.6/sound/card1/input10
kern :debug : rfkill: input handler disabled

grep "GRUB_CMDLINE_LINUX_DEFAULT" /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

awk 'BEGIN {IGNORECASE = 1; RS="\n\n"; FS="\n"; } /touch|mouse|synap/{print $0,"\n" }' /proc/bus/input/devices:
I: Bus=0003 Vendor=413c Product=301a Version=0111
N: Name="PixArt Dell MS116 USB Optical Mouse"
P: Phys=usb-0000:03:00.3-3/input0
S: Sysfs=/devices/pci0000:00/0000:00:08.1/0000:03:00.3/usb1/1-3/1-3:1.0
/0003:413C:301A.0001/input/input5
U: Uniq=
H: Handlers=mouse0 event5
B: PROP=0
B: EV=17
B: KEY=70000 0 0 0 0
B: REL=903
B: MSC=10

  • are they being detected by the system when you run xinput for the touchpad or lspci or lsusb (depending on the wifi device connection). Let's start with the touchpad, run xinput --short, and if you see an entry for your touchpad pointers and its corresponding id, run xinput test-xi2 [id] and see if anything from movement to keypresses or taps gets recognized. if nothing is found with xinput, run sudo dmesg -xt | grep -ai input and post the output – BarBar1234 Aug 23 at 23:28
  • I'll check tomorrow when I'm back in the shop. I'm pretty sure that I'm not seeing the touchpad but I can see the external mouse when I run xinput. Thank you for your help! I'll comment again in the morning tomorrow. – markymark Aug 26 at 2:28
  • I'm trying to post things correctly as I'm new on this forum. I'm sorry if I'm doing this poorly. I've edited my original post to include some of the outputs I got from the commands you had me run. Thank you! As far as I know I can't see an id for a trackpad on this laptop. @barbar1234 – markymark Aug 26 at 18:12
  • Its fine, the pasting of terminal outputs has been a little disfunctional for me aswell lately, because when I copypaste your log into an editor it fixes itself. I see what might be happening. I will type it up as an actual answer: – BarBar1234 Aug 26 at 18:26
  • @barbar1234 thank you so much for trying to walk me through this. Unfortunately the modprobes aren't returning anything even after those installs. I've again edited the post to include the outputs of those grep and awk inputs – markymark Aug 26 at 20:09
0

Ok, from your log output, it looks like Ubuntu is not detecting your touchpad, in that case run from terminal.

 $ sudo apt install xserver-xorg-input-synaptics xserver-xorg-input-libinput 
 $ sudo modprobe i2c_hid
 $ sudo modprobe psmouse
`

a reboot might be necessary, and if you see no change afterwards (after the reboot , execute the two sudo modprobe commands above again), please run in terminal:

$ grep "GRUB_CMDLINE_LINUX_DEFAULT" /etc/default/grub

and

$ awk 'BEGIN {IGNORECASE = 1; RS="\n\n"; FS="\n";  } /touch|mouse|synap/{print $0,"\n"  }' /proc/bus/input/devices

and post their outputs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.