1

When I want to install the CrossOver on my Debian XFCE I will get an error ...and I will run the command

 sudo dpkg --add-architecture i386; sudo apt-get update

but not solved.

enter image description here

When I run the sudo apt-get install libc6-i386

sanaebadi@debian:~$ sudo apt-get install libc6-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-i386 : Depends: libc6 (= 2.24-11+deb9u4) but 2.28-10 is to be installed
E: Unable to correct problems, you have held broken packages.
sanaebadi@debian:~$ 

I tried:

sudo apt-get autoclean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get -u dist-upgrade

Then I ran:

sudo dpkg --configure -a
sudo apt-get -f install

sudo apt-get install libc6-i386

... with the result:

sanaebadi@debian:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sanaebadi@debian:~$ sudo apt-get -u dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sanaebadi@debian:~$ sudo dpkg --configure -a
sanaebadi@debian:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sanaebadi@debian:~$ sudo apt-get install libc6-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-i386 : Depends: libc6 (= 2.24-11+deb9u4) but 2.28-10 is to be installed
E: Unable to correct problems, you have held broken packages.
sanaebadi@debian:~$ 

When I run lsb_release -a :

sanaebadi@debian:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.9 (stretch)
Release:    9.9
Codename:   stretch
sanaebadi@debian:~$ 

sources.list contents

# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 NETINST 20180714$

#deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 NETINST 20180714-$

deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stretch main contrib non-free

    deb http://security.debian.org/debian-security stretch/updates main contrib non$
    deb-src http://security.debian.org/debian-security stretch/updates main contrib$

    # stretch-updates, previously known as 'volatile'
    deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
    deb-src http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free


    deb http://httpredir.debian.org/debian/ stretch main contrib non-free
    deb https://dl.winehq.org/wine-builds/debian/ stretch main
    # deb-src https://dl.winehq.org/wine-builds/debian/ stretch main
    # deb-src https://dl.winehq.org/wine-builds/debian/ stretch main
    deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main
    # deb-src https://dl.winehq.org/wine-builds/ubuntu/ bionic main


    deb http://ftp.de.debian.org/debian stretch main contrib non-free

Results of apt update:

sanaebadi@debian:~$ sudo nano /etc/apt/sources.list
[sudo] password for sanaebadi: 
sanaebadi@debian:~$ sudo apt update
Ign:1 http://deb.debian.org/debian stretch InRelease                            
Hit:2 http://deb.playonlinux.com precise InRelease                              
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                    
Hit:4 http://deb.anydesk.com all InRelease                                      
Hit:5 http://linux.teamviewer.com/deb stable InRelease                          
Get:6 http://deb.debian.org/debian-security stretch/updates InRelease [94.3 kB] 
Hit:7 http://dl.google.com/linux/chrome/deb stable Release                      
Hit:8 http://repository.spotify.com stable InRelease                            
Get:9 http://ppa.launchpad.net/libreoffice/ppa/ubuntu eoan InRelease [20.7 kB]  
Err:9 http://ppa.launchpad.net/libreoffice/ppa/ubuntu eoan InRelease            
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 83FBA1751378B444
Hit:12 https://download.sublimetext.com apt/stable/ InRelease                   
Get:13 http://deb.debian.org/debian stretch-updates InRelease [91.0 kB]
Get:14 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease [17.6 kB]
Err:14 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C2518248EEA14886
Hit:15 http://deb.debian.org/debian stretch Release
Get:17 http://deb.debian.org/debian stretch-updates/main Sources.diff/Index [11.1 kB]
Get:18 http://deb.debian.org/debian stretch-updates/main i386 Packages.diff/Index [11.1 kB]
Get:19 http://deb.debian.org/debian stretch-updates/main amd64 Packages.diff/Index [11.1 kB]
Get:20 http://deb.debian.org/debian stretch-updates/main Sources 2019-08-14-2019.27.pdiff [554 B]
Get:20 http://deb.debian.org/debian stretch-updates/main Sources 2019-08-14-2019.27.pdiff [554 B]
Get:21 http://deb.debian.org/debian stretch-updates/main i386 Packages 2019-08-14-2019.27.pdiff [339 B]
Get:21 http://deb.debian.org/debian stretch-updates/main i386 Packages 2019-08-14-2019.27.pdiff [339 B]
Get:22 http://deb.debian.org/debian stretch-updates/main amd64 Packages 2019-08-14-2019.27.pdiff [339 B]
Get:22 http://deb.debian.org/debian stretch-updates/main amd64 Packages 2019-08-14-2019.27.pdiff [339 B]
Get:23 http://deb.debian.org/debian-security stretch/updates/main Sources [212 kB]
Get:24 http://deb.debian.org/debian-security stretch/updates/main i386 Packages [504 kB]
Err:11 http://www.getdeb.net/ubuntu wily-getdeb InRelease                       
  403  Forbidden [IP: 143.95.32.90 80]
Get:25 http://deb.debian.org/debian-security stretch/updates/main amd64 Packages [502 kB]
Get:26 http://deb.debian.org/debian-security stretch/updates/main Translation-en [225 kB]
Reading package lists... Done                                                   
W: GPG error: http://ppa.launchpad.net/libreoffice/ppa/ubuntu eoan InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 83FBA1751378B444
E: The repository 'http://ppa.launchpad.net/libreoffice/ppa/ubuntu eoan InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C2518248EEA14886
E: The repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://archive.getdeb.net/ubuntu/dists/wily-getdeb/InRelease  403  Forbidden [IP: 143.95.32.90 80]
E: The repository 'http://archive.getdeb.net/ubuntu wily-getdeb InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
sanaebadi@debian:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sanaebadi@debian:~$ sudo apt clean
sanaebadi@debian:~$ sudo apt autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sanaebadi@debian:~$ sudo apt install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sanaebadi@debian:~$ sudo apt purge libc6-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'libc6-i386' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sanaebadi@debian:~$ 

====================

Results of apt install libc6:i386:

sudo apt install libc6:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 hunspell-fr : Depends: hunspell-fr-classical but it is not going to be installed or
                        hunspell-fr-modern but it is not going to be installed or
                        hunspell-fr-revised but it is not going to be installed or
                        hunspell-fr-comprehensive but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

======================

sanaebadi@debian:~$ wget http://ftp.us.debian.org/debian/pool/main/g/glibc/libc6_2.24-11+deb9u4_i386.deb
--2019-08-23 17:06:12--  http://ftp.us.debian.org/debian/pool/main/g/glibc/libc6_2.24-11+deb9u4_i386.deb
Resolving ftp.us.debian.org (ftp.us.debian.org)... 64.50.236.52, 208.80.154.15, 64.50.233.100, ...
Connecting to ftp.us.debian.org (ftp.us.debian.org)|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2472274 (2.4M)
Saving to: ‘libc6_2.24-11+deb9u4_i386.deb’

libc6_2.24-11+deb9u4 100%[===================>]   2.36M   391KB/s    in 14s     

2019-08-23 17:06:27 (175 KB/s) - ‘libc6_2.24-11+deb9u4_i386.deb’ saved [2472274/2472274]

sanaebadi@debian:~$ sudo dpkg -i libc6_2.24-11+deb9u4_i386.deb
Selecting previously unselected package libc6:i386.
(Reading database ... 343220 files and directories currently installed.)
Preparing to unpack libc6_2.24-11+deb9u4_i386.deb ...
De-configuring libc6:amd64 (2.28-10) ...
Unpacking libc6:i386 (2.24-11+deb9u4) ...
dpkg: error processing package libc6:i386 (--install):
 package libc6:i386 2.24-11+deb9u4 cannot be configured because libc6:amd64 is at a different version (2.28-10)
dpkg: error processing package libc6:amd64 (--install):
 package libc6:amd64 2.28-10 cannot be configured because libc6:i386 is at a different version (2.24-11+deb9u4)
Errors were encountered while processing:
 libc6:i386
 libc6:amd64

=======================

sanaebadi@debian:~$ sudo gdebi crossover.deb
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done
This package is uninstallable
Cannot install 'libc6:i386'
sanaebadi@debian:~$ sudo dpkg -i crossover.deb
Selecting previously unselected package crossover:i386.
(Reading database ... 343221 files and directories currently installed.)
Preparing to unpack crossover.deb ...
Unpacking crossover:i386 (18.5.0-1) ...
dpkg: dependency problems prevent configuration of crossover:i386:
 crossover:i386 depends on libc6 (>= 2.11); however:
  Package libc6:i386 is not installed.
 crossover:i386 depends on libx11-6 | xlibs; however:
 crossover:i386 depends on libxext6 | xlibs; however:
 crossover:i386 depends on libxi6; however:
 crossover:i386 depends on libfreetype6; however:
 crossover:i386 depends on libpng12-0 | libpng16-16; however:
 crossover:i386 depends on libz1; however:
 crossover:i386 depends on libnss-mdns | lib32nss-mdns:amd64; however:
  Package lib32nss-mdns is not installed.
 crossover:i386 depends on libcups2; however:
 crossover:i386 depends on liblcms2-2; however:
 crossover:i386 depends on libglu1-mesa; however:
 crossover:i386 depends on libxcursor1; however:
 crossover:i386 depends on libxrandr2; however:

dpkg: error processing package crossover:i386 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 crossover:i386
1

Remove the non-Debian Repos

You should follow the recommendations here regarding your sources.list

Your sources.list should look like this:

deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

deb http://deb.debian.org/debian-security/ stretch/updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ stretch/updates main contrib non-free

deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free

The deb.debian.org address should automatically connect you to the whatever is the fastest mirror at that time. Source.

If you do require 3rd party repositories, which I recommend against if at all necessary (simply to avoid situations like this one), you need to make sure that they are for your current version of Debian. (Stretch in this case)

Run sudo apt update and sudo apt upgrade afterwards. If those complete successfully please move on to the next step.

Downgrade your current libc6 package

You need to remove the current version of libc6 from your system. Follow these steps:

sudo apt clean
sudo apt autoremove
sudo apt install -f
sudo apt purge libc6-i386

This should remove the package in question. However depending on the circumstances there may be packages that depend on this one package. Please update your post with the output of the last command and this question can be updated. (Alternatively you can try the advice pointed out here.)

Once the package has been removed we can install the right one following 1 of 2 steps. Either by following user alex_crow's advice of running sudo apt install libc6:i386. Again you may need to run sudo dpkg --add-architecture i386 and sudo apt update to complete this task.

Or you can directly download the package. Libc6 for stretch can be found here. You are looking for the libc6_2.24-11+deb9u4_i386.deb package. You can wget this package from a relevant mirror listed here. Example:

wget http://ftp.us.debian.org/debian/pool/main/g/glibc/libc6_2.24-11+deb9u4_i386.deb

Then run sudo dpkg -i libc6_2.24-11+deb9u4_i386.deb to install.

Verify you are following the Crossover Linux Install Sequence Correctly

Here is the Crossover Linux documentation on how to install the software. Verify that you have run these steps correctly. You may need to purge the existing packages from the botched first attempt at installing.

Download the latest version of the debian-based installer by opening a terminal:

wget http://crossover.codeweavers.com/redirect/crossover.deb

Teach the system about 32bit packages:

sudo dpkg --add-architecture i386

Bring the system up to date:

sudo apt-get update

The recommended methods to use for installing CrossOver on debian based systems are by using gdebi:

sudo gdebi crossover.deb

Or by using dpkg:

sudo dpkg -i crossover.deb

Since Crossover Linux is a commercial software project, if you have paid for the software I would consider directly contacting their support here and asking for assistance in installation.

Conclusion

Do Not Break Debian. Please make sure to read over all the links I have provided before running any commands. If you have any questions or there are any errors with my post please comment and I can edit this answer.

Best of Luck!

  • thanks dear, But the error not Solve .. and I update my post please see – sana ebadi Aug 23 at 21:11
  • 1
    @sanaebadi you need to downgrade all versions of libc6 you still have a 64bit version that is too "advanced". Depending on the circumstances of your FrankenDebian you may need to backup your data and reinstall, or dist-upgrade to Debian 10. – kemotep Aug 23 at 22:32
  • u mean should install Debian again? Nooo ..I am middle of Project Or Upgrade to Debian 10 . right ? – sana ebadi Aug 24 at 5:53
  • Dear, Now I have Debian 10 ..and I did not get the same error ..but get another error. Errors were encountered while processing: /var/cache/apt/archives/libc6_2.28-10_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1) – sana ebadi Aug 24 at 12:50
  • @sanaebadi I am afraid this is the issue with creating a mixed up version of Debian. Too many conflicts between the different versions and third parties. At this point you probably need to ask a new question based off of the current issues you are having. Again, if you absolutely need crossover Linux and you paid for it they should have support for assisting installation and you should contact them. Personally, I would start over at this point. You are only going to continue to have issues like this because of the earlier mix ups. – kemotep Aug 24 at 20:52
0

Please forgive me if this is a silly question, but have you tried installing libc6:i386 exactly as it's listed? As I understand it, the package "libc6-i386" is a collection 32-bit shared libraries for a 64-bit architecture. However, I think you want the actual 32-bit version of the package "libc6". As such, you need to specify "libc6:i386", instead of "libc6-i386". You'll probably want to ensure you have the 64-bit version installed as well. Please try the following, and let me know how it goes:

sudo apt install libc6
sudo apt install libc6:i386

Once you have libc6 and libc6:i386 installed, try installing libc6-i386 once again.

Also, take a look at the following package info for more information: https://packages.debian.org/stretch/libc6

Finally, I'd also recommend removing the Ubuntu repo for WINE from your sources.list file, instead opting for the Debian version, since you are indeed running Debian.

Hope this helps.

  • Thank u dear , I run your command , but sorry for that .. I break the result in 3 commands. – sana ebadi Aug 23 at 19:52
  • sanaebadi@debian:~$ sudo apt install libc6 [sudo] password for sanaebadi: Reading package lists... Done Building dependency tree Reading state information... Done libc6 is already the newest version (2.28-10). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. – sana ebadi Aug 23 at 19:52
  • sanaebadi@debian:~$ sudo apt install libc6:i386 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: – sana ebadi Aug 23 at 19:53
  • The following packages have unmet dependencies: hunspell-fr : Depends: hunspell-fr-classical but it is not going to be installed or hunspell-fr-modern but it is not going to be installed or hunspell-fr-revised but it is not going to be installed or hunspell-fr-comprehensive but it is not going to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. sanaebadi@debian:~$ – sana ebadi Aug 23 at 19:53
  • 1
    Interesting. It looks like you have the version of libc6 that's for Debian 10, instead of Debian 9 (the version you're running). It might be beneficial to uninstall the version of libc6 you have installed, then re-install to the proper version. To uninstall the current version, run: sudo apt remove libc6 Then, reinstall with: sudo apt install libc6 – alex_crow Aug 23 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.