0

So I am trying to see if I can ping another machine on my network and I tried a simple

ping

And I am getting 100% packet loss. I also tried to

ping google.com

Also getting 100% packet loss

Funny thing is that when I try tnsping (Oracle utility for pinging another database), I am actually able to ping the server I am looking for.

Am I using the ping command incorrectly? Or am I using the incorrect command?

  • "Or am I using the incorrect command". That depends on what you are trying to do. – guillermo chamorro Aug 23 at 15:28
  • ping <ip from your LAN> is not the same as ping google.com which needs an internet connection. – guillermo chamorro Aug 23 at 15:29
0

It is possible that the destination machine does not allow ICMP packets to be sent/received. You may also be trying to ping machine which is in a different, unreachable Subnet/VLAN.

tnsping seems to be using TCP/IP protocol, while ping is using ICMP protocol.

0

Well, if you are just typing ping then yes you are not using it correctly. ping --help or man ping will give you the syntax for using the ping command in linux.

You need to tell ping which computer you want to reach, either by IP address or hostname so to ping a host on your local network would look something like this:

ping 192.168.1.20 or ping fileserver

Pinging an internet host is the same ping google.com or ping 172.217.164.206

if the ping succeeds when using the IP address but not with the hostname then your problem is most likely a misconfigured DNS server in your network settings. Usually ping will give you an error message if something is really wrong like

Destination host unreachable or Name or service not known

If that is not the problem and you have access to another computer on your network go to it and try to ping the machine you are having the problem on. Sometimes there can be many things that can cause these types of problems. Firewalls Multiple network cards misconfigured settings etc.

So if you are still having the problem report back with as much information as possible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.