1

I want to do "single/continuous shot" using Pylon Viewer (version 5.2) in Debian 10 which is installed on VMWare. My host is windows 10.

On the host side everything works fine. I enabled "Jumbo Packet" for network interface in windows and it's value is 9014 Bytes. Under the host (Windows 10) I can stream from the camera "Basler acA1920-50gc" correctly if I change the packet size to 8192 in Pylon Viewer (as described in installation guide for pylon 5.2). But I can't stream it under the virtual machine. Basically, I have set the MTU of its network to 9014 and the packet size under transport layer is set to 8192, but it is not working and gives me the following error:

Error 2019-08-22 04:14:57.622 Basler acA1920-50gc (21967297) Image acquisition on "Basler acA1920-50gc (21967297)" failed! Error: 0xe1000014 "The buffer was incompletely grabbed. This can be caused by performance problems of the network hardware used, i.e. network adapter, switch, or ethernet cable. To fix this, try increasing the camera's Inter-Packet Delay in the Transport Layer category to reduce the required bandwidth, and adjust the camera's Packet Size setting to the highest supported frame size."

And the picture I get is black. If I set the Packet size to 1500, it will give me the picture but not completely, basically it contains thick black lines and after capturing the same error comes.

It seems changing MTU for Debian under VMWare does not work, although it shows the MTU correctly:

enter image description here

Is there something that I'm missing for changing MTU under Linux/Debian or in Pylon Viewer?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.