My issue is that I use Ctrl as a modifier in my Vim mappings. I use Alt as a modifier in my TMUX mappings. And coming from the Mac, I've grown accustom to using Command (i.e. Super) as the modifier for general OS shortcuts.

I've seen several posts on remapping keys, and perhaps I don't understand what that means in Linux terms, but I'm NOT looking to press Super+N (ex: New window) and have that send Ctrl+N to Linux. Doing this would mean my OS shortcuts would be in the same Ctrl namespace as my Vim mappings, which introduces collisions.

Is there a way to force Linux to respond to Super+some command key for all the built-in defaults that would otherwise expect Ctrl+some command key?

In other words, can I force Linux to use Super instead of Ctrl?

  • 1
    I'm not sure I understand your question right. Do you want Super+key to be the same as Ctrl+key? Doesn't that mean you're reassigning the Super to behave as Ctrl does? What will the difference be, though?
    – slybloty
    Commented Aug 21, 2019 at 23:19
  • 2
    "Linux" doesn't have "built-in defaults". Are you asking how to make Super the modifier for your window manager operations, and if so what window manager are you using?
    – icarus
    Commented Aug 21, 2019 at 23:23
  • 1
    Those shortcuts are usually built-in into applications. Some may allow you to change them, but I would not count on it.
    – Janka
    Commented Aug 21, 2019 at 23:57
  • 1
    @icarus I'm on Linux Mint (cinnamon) 19.2. And yes, that's precisely what I'm asking.
    – Nathan
    Commented Aug 22, 2019 at 0:22
  • 1
    From a google search, it appears that cinnamon is a very opinionated window manager and doesn't allow you to configure it much. Obviously you could edit the source and recompile it. I don't have anything useful to add.
    – icarus
    Commented Aug 22, 2019 at 3:29

1 Answer 1


Since that you are using Cinnamon open Settings->Keyboard->Shortcuts and change Ctrl to Super.

Do the same for the shortcuts of the apps that you want to change, sometimes there isn't an option so is not possible without recompiling the code.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .