2

enter image description here

After upgrading Fedora from 29 to 30, I noticed upon bootup that grub kept selecting the old 4.x kernel. No problem. I used package-cleanup to remove all but the latest two kernels. But now grub defaults to the rescue option.

It should remember my last chosen option and default to that but it isn't.

How can I fix this?


UPDATE

I've been unable to get this solved. I have tried:

  • Set dracut_rescue_image="no" in /usr/lib/dracut/dracut.conf.d/02-rescue.conf
  • Deleted initramfs.. and vmlinuz.. for the rescue kernel
  • Removed the dracut-config-rescue package
  • Deleted grub.cfg from /boot/grub2 and rebuilt it with grub2-mkconfig -o /boot/grub2.cfg (after all of the above)

I can confirm that dracut_rescue_image="no", the initramfs and vmlinux for the rescue kernel are still deleted. The rescue entry still remains in the grub prompt.

The entry remains but the system cannot boot with this entry and grub reports an error. But it's still the default selection... so now by default the system is unbootable without my selecting a different option.


UPDATE

I managed to remove the rescue option by deleting its entry in the /boot/loader/entries path. It is now defaulting to the 5.2.9 kernel but I don't know if the latest kernel will still be chosen after the next update. Because I don't know the source the initial problem, even with this solution, the cause is still a mystery.

To clarify, the default entry still is not the last chosen option, which is what I want. It is now just defaulting to the 5.2.9 kernel.

1
  • There is a very similar story (and solution) in this blog post (also after package cleanup (which removed GRUB 2, etc.)). Mar 9, 2023 at 15:30

1 Answer 1

0

I suspect your grub config got removed or corrupted somewhere along the way.

Here is a helpful manual

Basically look to see if GRUB_DEFAULT is set correctly. The --id here is example-gnu-linux.

menuentry 'Example GNU/Linux distribution' --class gnu-linux --id example-gnu-linux { ... }

then you can make this the default using:

GRUB_DEFAULT=example-gnu-linux

2
  • I want grub to always select the last option chosen. I don't want to hard-code an entry which I would then have to manually set every time I update the kernel.
    – Zhro
    Aug 27, 2019 at 14:59
  • As I understand it, that is something that you will have to do every time you update your configuration. Aug 28, 2019 at 0:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .