0

I am having issues with my brightness working on my laptop (stuck on max brightness); it uses the Intel HD 4000 graphics driver, however I had similar issues with it when I was using Windows 10, I found that using the default Microsoft Basic Display Driver that comes built in fixes this; which is a replacement for when software from hardware manufacture isn't installed.

Samsung ATIV Book 4 - NP470R5E-K01UB

  • current OS - Linux Mint 19.2 Xfce
  • Intel HD 4000 graphics driver
  • LED display

My overall question: Is there a Linux alternative to Microsoft Basic Display Driver? If so, how can I remove my current graphics driver and install that one?

My goal is to get the brightness controls to dim my display with the fn control keys.

Additional Info:

Read here: How to adjust brightness on Samsung ATIV Book 4, other users switched to Windows 10 from Windows 8 experienced same problem.

Currently using Brightness Controller program to dim my display as xbacklight does not work, xrandr does work but unable to figure out how to connect it to my fn keys

ls /sys/class/backlight/ # gives me intel_backlight

Running inxi -Fzxi yields;

System:
  Host: David Kernel: 5.0.0-25-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: Xfce 4.12.3 Distro: Linux Mint 19.2 Tina 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: SAMSUNG product: 3570R/370R/470R/450R/510R v: P08RAN 
  serial: <filter> 
  Mobo: SAMSUNG model: NP470R5E-K01UB v: SEC_SW_REVISION_1234567890ABCD
  serial: <filter> UEFI: American Megatrends v: P08RAN.106.130528.ZW
  date: 05/28/2013 
Battery:
  ID-1: BAT1 charge: 35.4 Wh condition: 36.5/43.1 Wh (85%)
  model: SAMSUNG Electronics SR Real Battery status: Unknown
CPU:
  Topology: Dual Core model: Intel Core i5-3230M bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 20752 
  Speed: 1198 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1198 2: 1197 
  3: 1197 4: 1197 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Samsung Co
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.0.8 
  direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Samsung Co driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.0.0-25-generic 

Solutions Tried:

Created a 20-intel.conf file in /usr/share/X11/xorg.conf and /etc/X11/xorg.conf with the following;

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

Tried the following grub configurations:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=video"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi="
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=Linux"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=intel_backlight"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=intel_backlight"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=intel"
#This last option made it dimmer but didn't allow brightness control

Links: brightness-controller-for-ubuntu, fix-brightness-ubuntu, ubuntuforums-thread

  • Try the video.use_native_backlight=1 kernel option, too. – Janka Aug 31 '19 at 19:03
1

Okay, after multiple attempts on my machine, given our systems are similar, here is what I did and it worked.

have a file in/usr/share/X11/xorg.conf titled 20-intel.conf

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "acpi_video0"
        BusID       "PCI:0:2:0"
EndSection

note how it directs to acpi_video0 instead of intel_backlight

next was to tackle /etc/default/grub set GRUB_CMDLINE_LINUX_DEFAULT to

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux acpi_backlight=acpi_video0"

now I'm not entirely if this will help but, this is something I did earlier and I'm not sure if it affects what is above.

I also followed the ArchWiki about setting an udev rule for users in the video group

/etc/udev/rules.d/backlight.rules

ACTION=="add", SUBSYSTEM=="backlight", KERNEL=="acpi_video0", RUN+="/bin/chgrp video /sys/class/backlight/%k/brightness"
ACTION=="add", SUBSYSTEM=="backlight", KERNEL=="acpi_video0", RUN+="/bin/chmod g+w /sys/class/backlight/%k/brightness"

so add yourself to the video group and update grub too and hopefully upon reboot it works.

(sorry about formatting and stuff, I am new to linux and to forums it seems)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.