0

I inputted a partitioning standard, msdos, and got a message: you may need to update "/etc/fstab".

My usb card-reader will not mount now. "lsblk" shows sdb/sdb1, but sdb/sdb1 will not mount. Appears that I need to update /etc/fstab, but not sure if this is the only reason.

To update /etc/fstab, I tried "mount -a"; didn't work - haven't found any other commands for it yet.

The output is " / = ignored" "/tmp = already mounted". I didn't put anything into "/etc/fstab" as permission denied. Partitioned with "sudo fdisk /dev/sdX"

parted /dev/sdb1 print
Error: /dev/sdb1: unrecognised disk label
Model: Unknown (unknown)                                                  
Disk /dev/sdb1: 15.9GB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags: 
 parted /dev/sdb print
Model: Generic STORAGE DEVICE (scsi)
Disk /dev/sdb: 15.9GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  15.9GB  15.9GB  primary

update: after jumping through numerous hoops, deleting, creating, partition standard changed, formatting... It is now partitioned and recognized.

  • what's the output of mount -av? what did you put into /etc/fstab? what did you partition the disk with? – Bart Aug 20 at 15:03
  • check as well this: blog.hostonnet.com/parted – Bart Aug 20 at 15:05
  • try editing /etc/fstab with sudo, you need elevated permissions to edit that file. please also put the update to the ticket body instead of a comment. – Bart Aug 20 at 15:10
  • @Bart Tried in sudo, didn't work. – veagle88 Aug 20 at 15:12
  • what does lsattr /etc/fstab say? – Bart Aug 20 at 15:12
0

Formatting seemed to be the key. After that I had to redo some things involving the deleting and creating partitions and altering the partition standard. I don't remember the exact sequence of things.

  • Thanks to all who contributed! – veagle88 Aug 25 at 23:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.