1

Since I've installed Debian 10 Buster on my laptop I'm not able to shutdown or reboot my computer properly. I've re-installed the OS countless times with no success. I'm using LXDE as DE.

Whenever I press the shutdown or reboot buttom from the GUI or I use the terminal to type the dedicated commands my system hangs for more than twenty minutes on Reached target Power-Off or Reached target Reboot.
I've edited the grub configuration file removing the quiet boot option and I've found out the last thing systemd is trying to do is Stopping disk when shutting down, or Synchronizing SCSI cache when rebooting.

After reading this I tried both poweroff -f and reboot -f and none of them worked.
So is this a kernel related issue? I don't know how to proceed.

I've even saved my systemd shutdown log with debug options enabled.

  • Can you do an lscpu |grep -i model and check if that model is a Bay Trail one? Could be related to the bay trail issues. – Panagiotis Aug 21 at 18:50
  • It's not a Bay Trail One, it's a 2009 or so ASUS laptop. This is the console output: Model: 23 Model name: Pentium(R) Dual-Core CPU T4400 @ 2.20GHz. – matteobin Aug 24 at 12:17
  • @matteobin did you find the solution? I'm facing the same problem – Nandan Desai Aug 26 at 12:23
  • @NandanDesai nope, but I'm still working on it. I decided to move the conversation to the Italian Debian mailing list since it seems more active. – matteobin Aug 26 at 19:43
  • @matteobin oh cool. Please remember to leave a solution here if you find any. It would be much appreciated. Thanks. – Nandan Desai Aug 27 at 14:08
0

tl;dr - I've upgraded my BIOS to fix it.

I had this same exact issue with my older Dell laptop. I am fairly certain that it has to do with the kernel 4.19 after upgrading from 4.9 when going from Stretch to Buster. My best guess is that the BIOS (at least mine) have a semi-broken ACPI implementation but the older kernel was able to tolerate it by sending it what it wants to change states.

If you are already on the latest BIOS for your hardware, you may be SOL and either would have to try the latest kernel or downgrade the kernel. I am no expert in this area and thus perhaps someone with a better understanding can look into the differences between 4.9 and 4.19 in the ACPI power states handling.

There are other posts regarding 4.9 being fine as well but 4.19 is broken for them which also reinforces this theory: https://superuser.com/questions/1437586/debian-10-buster-computer-wont-power-off-completely-nor-suspend-hibernate

I hope this helps at least someone.

  • I tried upgrading the BIOS but nothing changed. – matteobin Oct 3 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.