1

I have been compiling a kernel for my Android device and there is this problem that I have encountered.

I have ported the kernel from v3.10.108 to 3.18.

I have got the kernel to last part and solved almost every issue it had.

The place I am getting stuck at is in the early user space init where it loads the rootfs but for that to happen.

I need the /init binary to execute but is fails and does not find any init file.

I have tried adding bootargs but they have just failed

[    1.147003] Freeing alternatives memory: 112K
[    1.147072] Failed to execute /init (error -2)
[    1.147093] Failed to execute /init
[    1.147114] Failed to execute /init (error -2).  Attempting defaults...
[    1.147172] Kernel panic - not syncing: No working init found.  Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.

Above message is what I get each time.

Can Someone Explain what I am doing wrong or something I am missing?

Source of my kernel: https://github.com/tejasudupa/3.18-kernel-kenzo

I have added all the proper configs but still it fails.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.