I just installed debian 10, but it wants able to make it autologin into mate after the boot, Im using gdm and try to edit the


Uncomented the autologin and user lines but this makes the system simple stopped to both.

1 Answer 1


Try use lightdmcfg -- GUI to configure LightDM display manager LightDM Configurator (lightdmcfg) is a program to configure LightDM display manager. Features: - session selection

  • enable/disable guest session
  • autologin setting
  • theme change
  • hide/show user list


sudo add-apt-repository ppa:fsnow/ppa
sudo apt-get update 
sudo apt-get install lightdmcfg  

Documentation for lightdmcfg - /usr/share/doc/lightdm/lightdm.conf.gz There are a bunch of settings. Dependency (if needed) this and this.

Author - FSnow

Forum (on russian) - http://forum.runtu.org/index.php/topic,2586.0.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.