1

I have a problem with Linux Mint and video playback.

The issue is that opening any .mp4 from disk (don't have any other filestypes) results in video player crash. Tried many different players like vlc (which crashes), mplayer (fails with Exit Code 11) et cetera.

Also YouTube videos crash Firefox. Chromium plays YouTube videos but is very choppy. This may or may not be a separate issue.

As far as i see i have everything installed. Drivers, codecs, apps. Im at loss as to why this happens. Having been asking around people seem to suggest the machine is too old and slow but i disagree. We are talking about HD or FHD video playback here not 4K or something like that. If the motherboard and APU are under powered, it would be choppy but it would not outright crash.

This leads me to believe it's some sort of software configuration/conflict issue. Below is inxi -F && dmesg | grep -i error output:

System:
  Host: eve Kernel: 4.15.0-58-generic x86_64 bits: 64 
  Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina 
Machine:
  Type: Desktop Mobo: MSI model: H61M-P31 (G3) (MS-7788) v: 1.0 serial: N/A 
  UEFI: American Megatrends v: 2.7 date: 01/10/2013 
CPU:
  Topology: Dual Core model: Intel Celeron G550 bits: 64 type: MCP 
  L2 cache: 2048 KiB 
  Speed: 2594 MHz min/max: 1600/2600 MHz Core speeds (MHz): 1: 2594 2: 2594 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  driver: i915 v: kernel 
  Display: server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel Sandybridge Desktop v: 3.3 Mesa 19.0.8 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k4.15.0-58-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: d4:3d:7e:18:a9:53 
Drives:
  Local Storage: total: 223.57 GiB used: 106.59 GiB (47.7%) 
  ID-1: /dev/sda vendor: Patriot model: Burst size: 223.57 GiB 
Partition:
  ID-1: / size: 217.61 GiB used: 106.58 GiB (49.0%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 194 Uptime: 18h 02m Memory: 3.56 GiB used: 1.17 GiB (32.8%) 
  Shell: bash inxi: 3.0.32

Im not a first time Linux user and the PC is not mine. But im also not super experienced in Linux tho i seem to have little problem using the terminal. I can access the PC with remote management if nessesary to test things.

So far i have tried:

Install FFmpeg - no change
Install mplayer - no change
Install ubuntu-restricted-extras - was already installed
Switch VLC video output to X11 - no change
monitor CPU usage during playback - near 100% on both cores during youtube playback via Chromium.
update libva - was already installed
update vaapi - was already installed
sudo apt-get update && sudo apt-get install vlc - no change
sudo apt-get dist-upgrade - no change

Driver manager shows no proprietary drivers avaliable or installed. Everything else seems to work just fine.

I think i might need to try and use Intel's legacy video driver instead of modesetting. As i understand modesetting is better on newer hardware but legacy is better on legacy hardware.

Problem is, I can't seem to find the specific command to do this.

EDIT:

Ok so i tried using the Linux Mint live usb version (same from where i installed Mint) and when opening video via file manager it requested 2 downloads. One was gstreamer and i don't remember what the other one was - MPEG4 something.... It was then able to play back the video just fine after that.

So it seems the hardware is capable and it's not a problem with Mint but there is some sort of software configuration issue with the installed version.

  • As a simple and quick troubleshooting step, what happens if you generate a LiveUSB from Lubuntu lubuntu.net/downloads or some other non-Mint distro, and play the movie from that? Please advise by clicking edit then post the result into your question; please do not use Add Comment, but instead use edit. – K7AAY Aug 19 '19 at 18:53
  • I'm not familiar with Intel graphics or modesetting, but ArchWiki suggests that modesetting can be problematic in some cases. The intel driver may fix that. – rudib Aug 19 '19 at 21:32
  • "Intel does not provide direct downloads and technical support for Linux drivers. The Intel Graphics Linux driver is primarily supported through the original equipment manufacturer (OEM) (i.e., MSI), the Linux distribution vendor, or by the Intel Open Source Technology Center at 01.org/linuxgraphics/downloads/stack . For more information, see the Drivers for Linux document intel.com/content/www/us/en/support/articles/000005520.html for more details." - intel.com/content/www/us/en/support/articles/000005526/… – K7AAY Aug 19 '19 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.