5

I am using a MacBook Retina with four processor cores on Linux (Ubuntu 18.04):

$ grep -E '^model name|^cpu MHz' /proc/cpuinfo
model name  : Intel(R) Core(TM) i5-4258U CPU @ 2.40GHz
cpu MHz     : 799.976
model name  : Intel(R) Core(TM) i5-4258U CPU @ 2.40GHz
cpu MHz     : 799.993
model name  : Intel(R) Core(TM) i5-4258U CPU @ 2.40GHz
cpu MHz     : 799.992
model name  : Intel(R) Core(TM) i5-4258U CPU @ 2.40GHz
cpu MHz     : 800.016

In order to enable this governor (and the on-demand one), I switched to the acpi-cpufreq driver. Follwoing instructions at (Setting CPU governor to on demand or conservative) and (https://ubuntuforums.org/showthread.php?t=1767485), I had to enable two kernel flags in grub.cfg:

intel_pstate=disable processor.ignore_ppc=1

Anyway. This is what cpufreq-info gives me:

  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 3
  CPUs which need to have their frequency coordinated by software: 3
  maximum transition latency: 10.0 us.
  hardware limits: 768 MHz - 2.40 GHz
  available frequency steps: 2.40 GHz, 2.40 GHz, 2.30 GHz, 2.00 GHz, 1.80 GHz, 1.50 GHz, 1.30 GHz, 1.10 GHz, 900 MHz, 768 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance, schedutil
  current policy: frequency should be within 768 MHz and 2.40 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 800 MHz.

So the 768-2400MHz hardware limits are well known, but somehow it refuses to move away from the 800MHz. I tried with ondemand with no more success.

Now here is the funny part. If I simply use cpupower frequency-info, I get

  current CPU frequency: Unable to call hardware
  current CPU frequency: 800 MHz (asserted by call to kernel)

However, if I call cpupower as root, I get

  current CPU frequency: 2.40 GHz (asserted by call to hardware)

How the heck is this possible? The kernel and the hardware report different values (and it feels slow, so I'd trust the kernel). Do you have any clue as to what could be the issue here?

  • Same here. Did you get a solution ? – MickaelFM yesterday
  • @MickaelFM I did not, though I tried for a long time. I would particularly like to understand why cpupower is giving me different values... – Dune 16 hours ago
  • I wrote my own question. It may be a hardware problem in my case. askubuntu.com/questions/1205805/cpu-frequency-capped/… – MickaelFM 14 hours ago
  • About the discrepancies on your frequencies, between being root or not, they come from the fact that being root it displays the target frequency set by the OS. It wants to go to 2.4GHz (your CPU max freq) but is capped by something else. – MickaelFM 14 hours ago
  • It is probably a hardware problem in my case as well then. Thanks for the link and the explanation @MickaelFM – Dune 8 hours ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.