3

I installed VMware Horizon client on my Fedora 29 machine. I downloaded the VMware-Horizon-Client-4.10.0-11053294.x64.bundle file from VMware official download page.

When I am running it by searching in the system, it's not running. And when I tried running it from CLI by using command vmware-view it is showing below error

/usr/lib/vmware/view/bin/vmware-view-crtbora: symbol lookup error: /usr/lib64/libpangomm-1.4.so.1: undefined symbol: ZN4Glib6ObjectC2EOS0

I tried searching that library in dnf repos, but unable to find any by name.

I tried solution mentioned here, but no luck.

1 Answer 1

3

Using the vmware-view command in /usr/bin will use the system libraries instead of the ones included with the View Client.

After installation, prepend the Vmware View libraries to your LD_LIBRARY_PATH and the bin directory in the installation folder to your PATH:

export LD_LIBRARY_PATH=/usr/lib/vmware:$LD_LIBRARY_PATH
export PATH=export PATH=/usr/lib/vmware/view/bin:$PATH

The vmware-view command will then open the client GUI as it will be the one in /usr/lib/vmware/view/bin/vmware-view and not the one in /usr/bin. You can verify this with which vmware-view. This will use the View Client binaries and libraries and not the system binaries and libraries. You can add the two export commands to your ~/.bashrc so that it sets them at login.

2
  • I actually installed version 4.8 and it is working fine now. However, I will try your suggestion as well. Aug 18, 2019 at 18:15
  • 1
    @imvpn22 I did the same at first and found that 4.9 will also work with the system binary and libraries. Afterwards, I was able to get it to work with 4.10 so I used that one for my answer. Aug 18, 2019 at 18:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .