2

Here I am repeating a question previously asked in a sister forum, as it is relevant here and I have neither received a response, nor been able to resolve the issue.

On my ThinkPad T470 which is a dual boot with Linux Ubuntu 18.04 and Windows 10, everything was working fine in Ubuntu until after a while I needed to boot Windows. Since then, the fan on the laptop runs constantly at full speed on Ubuntu.

I have tried the common solutions such as setting acpi_osi=!Windows 2012 in the grub setting according to this answer or setting fan speed using thinkfan according to this answer.

I have also checked my BIOS setting, but every thing looks normal as some options are set for performance and some set to be balanced between performance, energy consumption, and fan noise. The problem is Ubuntu seems to not recognize the BIOS settings or any other settings for that matter.

None of the solutions above made any difference in the fan noise.

Any help would be appreciated.

GUESS: I am suspicious about ACPI not doing its job for some reason.

OBSERVATION 1: One observation that may be worth mentioning is that the fan runs at normal/low speed when I boot the laptop and the grub menu prompts me to choose an operating system (Ubuntu or Windows) to continue with. Then the fan takes off to full speed as I choose Ubuntu. I think this means that BIOS settings work fine.

OBSERVATION 2: Trying to use fancontrol according to this answer, after running sudo pwmconfig, I get the following message:

hwmon3/pwm1_enable stuck to 2
Manual control mode not supported, skipping hwmon3/pwm1.
There are no usable PWM outputs.

EDIT 1: The power settings in Ubuntu doesn't seem to alter fan speed.

EDIT 2: Fan runs normally on Windows.

EDIT 3: The BIOS version on my machine is 1.59

  • Does ubuntu has some power performance setting? Are you always connected to the power outlet? Just guessing – vfbsilva Aug 17 at 17:46
  • (Ubuntu or Windows). I guess that when running windows the problem desappears. I ask because can you be sure that't is not a hardware problem? – guillermo chamorro Aug 17 at 18:29
  • Is your BIOS version >= 1.43? See n1quj25w.txt: "UEFI: 1.43 / ECP: 1.29 Fix) Fixed an issue where fan might rotated with max speed due to not reading CPU temperature correctly." – Freddy Aug 17 at 23:44
  • @vfbsilva Thank you for your comment. Ubuntu power settings doesn't seem to alter fan speed. – Pooya Aug 18 at 19:00
  • @guillermochamorro Thanks for the comment. Yes, the fan runs normally in Windows. – Pooya Aug 18 at 19:01
3

It sounds like you are going to have to do some manual intervention to get ACPI working properly with your hardware

https://github.com/vmatare/thinkfan/

echo "options thinkpad_acpi fan_control=1" > /etc/modprobe.d/thinkfan.conf

Load the module like this.

$ su
# modprobe thinkpad_acpi
# cat /proc/acpi/ibm/fan

Then enable the module

Systemctl enable thinkfan

You will need to configure temp profile by editing the

/etc/thinkfan.conf

Examples are provided as thinkfan.conf.simple

Good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.