0

Trying to install etcher. I have a command for it, but it appears to be for 64-bit (ie: "amd64.deb"). I changed the 64 to 32 in the command line, but it does not work. I spent 3-hours trying every command I could find online, but have not been able to get it to install/run. I have the 'AppImage' and tried different commands with this, but also no success. I have successfully installed it in the past with ubuntu, but on a 64-bit computer.

I'm using debian 10, buster, armbian architecture. Thanks. Here's the 64-bit command I tried, changing 64 to 32 - the command that worked on the 64bit:

sudo apt-get install gdebi
sudo wget https://github.com/resin-io/etcher/releases/download/v1.1.1/etcher-electron_1.1.1_amd64.deb
gdebit filename.deb
  • You can't just change 64 to 32: You need a 32 bit .deb, and this link doesn't provide one. So you can install the AppImage from the main site (this probably needs Electron, too, I didn't try it). Alternatively, just flash your USB sticks and SD cards from the command line with cp or dd (I never understood why people need Etcher, flashing under Linux is really simple). – dirkt Aug 17 '19 at 15:46
  • Thanks.Do you have a command line command for cp or dd? Even when I got the 'AppImage', I used multiple online suggested commands, and was not able to get it to run. What do with the 32-bit AppImage? – hddfsck777 Aug 17 '19 at 15:50
  • lsscsi to identify your USB stick etc. Let's say it's /dev/sde, then do cp your_image /dev/sde. Careful, if you pick the wrong one, you can overwrite other harddisks etc., so double check. – dirkt Aug 17 '19 at 15:52
  • Thanks. For the "image", do you mean the "AppImage"? – hddfsck777 Aug 17 '19 at 15:54
  • 2
    32bits balena-etcher-electron github.com/balena-io/etcher/releases ... : balena-etcher-electron_1.5.53_i386.deb – Knud Larsen Aug 17 '19 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.