0

I am running Fedora 30 with i3-gaps on my laptop and using compton as a compositor. When I try and set transparent borders in my i3 config, borders on most apps appear as solid black. It affects Nautilus, Firefox, Chrome, Spotify, VirtualBox, etc.

The borders on urxvt are transparent, as are other parts of my setup such as polybar and rofi, so compton is not entirely broken.

The transparency is set in my i3 config here:

set $bg-color            #ff000050
set $border-color        #ff000050
set $indicator-color     #008cff50
set $inactive-bg-color   #ffffff00
set $text-color          #ababab
set $inactive-text-color #676E7D
set $urgent-bg-color     #E53935
set $ws-focused-bg       #000000

# window colors
#                       border              background         text                 indicator
client.focused          $border-color       $bg-color          $text-color          $indicator-color
client.unfocused        $inactive-bg-color  $inactive-bg-color $inactive-text-color $inactive-bg-color
client.focused_inactive $inactive-bg-color  $inactive-bg-color $inactive-text-color $inactive-bg-color
client.urgent           $urgent-bg-color    $urgent-bg-color   $text-color          $urgent-bg-color

Using the last two digits in the hex to set the alpha value.

I also use the line

for_window [class=".*"] border pixel 1

to give the borders with no title bars on i3-gaps.

Any ideas on how to fix this?

EDIT: My compton config is currently:

detect-client-opacity = true;
shadow-exclude = [
        "class_g = 'Firefox' && argb"
];
frame-opacity = 0.0;
  • Can you supply more details as to how you're setting these borders to be transparent in your i3 config? Post the relevant part of your config w/ your question. – garzai Aug 15 at 19:20
  • Edited the question to add that now – Harry Cooke 2 days ago
  • In i3 (and i3-gaps), only the i3bar supports transparency; RGBA. The other colors, such as window borders, only support RGB. As I understand it, compton has a way to set the transparency of the "window frame", which in i3 would be the border. – Emmanuel Rosa 2 days ago
  • I have added my compton config to my question - I did have frame-opacity set to zero already. I tried changing my RGBA colours to RGB in the i3 config in case that was interfering with it, but all that achieved was removing transparency from urxvt borders and made my borders white instead of black (as I changed #ffffff00 to #ffffff). – Harry Cooke 2 days ago
  • However, even if I can get the right command in the compton config, I want the borders to have varying transparency depending on focus. I.e. fully transparent if not focused and some lesser level of transparency otherwise. – Harry Cooke 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.