2

I have a 64-bit Sabayon Linux and Mac OS X dual boot. After using gparted to resize my partitions, I can no longer boot Sabayon. I've tried chrooting and fixing grub from several live CDs, but they have all said "command not found" about either grub or chroot. Knoppix came close but then said it couldn't restore grub because it's 32 bits, rather than 64 like my Sabayon installation. Tips?

1

Try archlinux live discs, they surely have chroot working (repaired my systems several times with them).

Find the ISOs here

I reccomend "dual", as they have 32 and 64 bit versions of archlinux.

  • Thanks. I booted from Arch and successfully chrooted, but Arch doesn't recognize the grub or grub-install commands. I noticed Arch has /sbin/grub2-install, tho – strangeronyourtrain Jan 4 '11 at 9:12
  • (Last comment got cut off) I noticed Arch has /sbin/grub2-install, though. I tried "/sbin/grub2-install /dev/sda4" and got a warning about how it's a bad idea to not install to MBR and how grub can only be installed with blocklists, which are unreliable. I'm not sure what to do; I'm using Refit on the MBR in order to dual-boot with OS X, so I'm afraid of messing that up. – strangeronyourtrain Jan 4 '11 at 9:17
  • Oh, I finally got it! I used the Arch live cd with the instructions here: ubuntuforums.org/showpost.php?p=121355&postcount=5 – strangeronyourtrain Jan 4 '11 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.