0

On the Thinkpad X230 laptop, sensitivity of left button (the three big buttons between keyboard and Touchpad) that makes mouse left click is very high. It clicks if I just place finger on it without pressing. So accidentially touching it makes mess (cursor is moved, etc.). How to configure it correctly? Now I disabled TrackPoint at all. Here are configurations using xinput:

[art@arch-pc ~]$ xinput list-props 12
Device 'TPPS/2 IBM TrackPoint':
    Device Enabled (162):   0
    Coordinate Transformation Matrix (164): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Natural Scrolling Enabled (305):   0
    libinput Natural Scrolling Enabled Default (306):   0
    libinput Scroll Methods Available (309):    0, 0, 1
    libinput Scroll Method Enabled (310):   0, 0, 1
    libinput Scroll Method Enabled Default (311):   0, 0, 1
    libinput Button Scrolling Button (323): 2
    libinput Button Scrolling Button Default (324): 2
    libinput Middle Emulation Enabled (315):    0
    libinput Middle Emulation Enabled Default (316):    0
    libinput Accel Speed (317): 0.000000
    libinput Accel Speed Default (318): 0.000000
    libinput Accel Profiles Available (325):    1, 1
    libinput Accel Profile Enabled (326):   1, 0
    libinput Accel Profile Enabled Default (327):   1, 0
    libinput Left Handed Enabled (319): 0
    libinput Left Handed Enabled Default (320): 0
    libinput Send Events Modes Available (282): 1, 0
    libinput Send Events Mode Enabled (283):    0, 0
    libinput Send Events Mode Enabled Default (284):    0, 0
    Device Node (285):  "/dev/input/event17"
    Device Product ID (286):    2, 10
    libinput Drag Lock Buttons (321):   <no items>
    libinput Horizontal Scroll Enabled (322):   1

Using ArchLinux.

enter image description here

Devices are:

art@arch-pc ~]$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=11   [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C           id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=13   [slave  keyboard (3)]
  • What is your desktop environment? – JoKeR Aug 13 at 20:31
  • @JoKeR KDE Plasma. I'm attaching screenshort. But settings there don't help. – Artyom Aug 14 at 10:31
0

Launch the System Settings look for mouse and touchpad icon.

Toggle these settings below

shot

You can disable it while you are typing or change it to click instead of tap.

There you can find other settings as well that might come in handy.

  • Those are for touchpad not for TrackPoint buttons. The problem with the button. – Artyom Aug 14 at 10:31
  • I see now. Actually I just watched youtube video and it seems to be the product itself with such behavior the new Lenovo trackpoint according to users there are some complaints saying it is messed up it's too touchy and sensitive. So I guess that is what you are experiencing, for now I don't know if there's a fix perhaps Lenovo programmers will fix it in future firmware releases. – JoKeR Aug 14 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.