1

I am using Deepin Linux 15.11 and want do install fwupd (LVFS) with apt / apt-get which allows firmware updates from within Linux.

Unfortunately Deepin's package repo provides a badly outdated version of fwupd :(. An uptodate version of fwupd is available on Debian buster repo. I've already added deb [arch=amd64] https://download.docker.com/linux/debian buster stable to /etc/apt/source.list

How do I tell apt to update only fwupd from debian buster instead from deepin lion?

NOTE @admin: can you please add tags "fwupd" and "LVFS" to this post and remove this line. (I have not sufficient privileges to add new tags)

1

You can pin the package with a higher priority than the package from Debian Buster in /etc/apt/preferences.d/fwupd.

You can view an example here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.