1

Regarding the below link, I am also getting the error when I tried to install/configure docker in RHEL 7 Error starting docker service: Unit not found

Failed to start docker.service: Unit not found.

and when I tried

 systemctl status docker -l  

the output gives me nothing.

Am inside a firewall of my organization and the user id am login inside Linux machine is different from my company user ID.

Login credentials for linux machine doesn't have internet access whereas my companyid can access google.com inside a browser.

So, does any issue with internet connection exists while running the docker install?

When I tried to create a file docker.socket in the system directory, it's giving "permission denied".

 [Unit]
 Description=Docker Socket for the API
 PartOf=docker.service

  [Socket]
  ListenStream=/var/run/docker.sock
  SocketMode=0660
  SocketUser=root
  SocketGroup=docker

  [Install]
  WantedBy=sockets.target

So, what am missing, where exactly I need to get privileges?

When I tried with my creds, its giving me "root", so I think, am running as admin user only.

  • 1
    Did you install the RHEL docker package or did you install docker some other way? Did you run systemctl daemon-reload? – Rafael Kitover Aug 12 at 14:34
  • No, I only tried to run the docker command only in the command line way only after my satellite registration. Yes, I have ran the cmd, systemctl daemon-reload. but no success! – user593450 Aug 12 at 15:55
  • Have you tried any of these methods: cyberciti.biz/faq/… – Rafael Kitover Aug 12 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.