0

My pop!_os 18.04 does not have minimize and maximize buttons, after check from this link, I try to install gnome-tweak-tool, then I get a series of dependency errors.

x@pop-os:~$ sudo apt install gnome-tweak-tool
[sudo] x password:
Reading list of packages... done
Analyzing the dependency tree of the package
Reading status information... done
There are some packages that cannot be installed. If you are using an unstable distribution, this might be
Because the system is unable to reach the state you requested. There may be some software you need in this release.
The packages have not been created or they have been moved out of the Incoming directory.
The following information may be helpful in resolving the issue:

The following packages have unmet dependencies:
  Gnome-tweak-tool : Dependency: gnome-shell-common (>= 3.4) But it won't be installed
E: I can't fix the error because you want some packages to stay current, that is, they break the dependencies between the packages.

But when I try to install gnome-shell-common, it indicates the latest version has been installed, anyone know how to fix this? Thanks.

x@pop-os:~$ sudo apt install gnome-shell-common
Reading list of packages... done
Analyzing the dependency tree of the package
Reading status information... done
Gnome-shell-common is the latest version (3.28.4-0ubuntu18.04.2).
Gnome-shell-common has been set up for manual installation.
0 packages have been upgraded, 0 packages have been newly installed, 0 packages have been uninstalled, and 22 packages have not been upgraded.
  • Could you edit your question to show the output of apt policy gnome-tweak-tools? Does it work better if you try to install gnome-tweaks instead? – Stephen Kitt Aug 12 '19 at 15:13
1

The problem here is your distribution ships an older version of GNOME-shell-common (3.28) when at least 3.4 is required for gnome-tweak-tools

That's a distribution problem not a you problem

EDIT: apparently 3.28 is actually newer than 3.4. However, it's till an issue with your distro

| improve this answer | |
  • 3.28 is newer than 3.4. It’s not “3.2.8”, it’s 3.28. – Stephen Kitt Aug 12 '19 at 15:10
  • @StephenKitt then why does it insist its older? It's says >=3.4 and according to you, 3.28 > 3.4 – unixandria Aug 13 '19 at 13:20
  • It doesn’t insist it’s older. The error message says that gnome-tweak-tools requires gnome-shell-common 3.4 or later, and that it can’t install it, it doesn’t say that version 3.28 of the package doesn’t satisfy that. The whole question doesn’t make all that much sense though because the versions involved don’t match anything released, and the gnome-tweak-tool package which is supposed to be used here should depend directly on gnome-tweaks. For Pop!_OS 18.04 the OP should be getting version 3.28.1-1 of gnome-tweaks. – Stephen Kitt Aug 13 '19 at 13:28
  • For context, version 3.4 was released in 2012. Version 3.28 was released in 2018. – Stephen Kitt Aug 13 '19 at 13:29
  • @StephenKitt edited to include that info – unixandria Oct 17 '19 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.