0

I'm working on a GTK3 theme and I use GTK_DEBUG=interactive to test changes in the CSS.

I start an application with the gtk inspector attached, I launch it with:

$ GTK_DEBUG=interactive <name>

This works for normal applications but not for MATE's file manager Caja. When used with Caja, the application appears to launch, then close, then open again and appears without the gtk inspector.

I tried:

$ kilall caja && GTK_DEBUG=interactive caja

But this had the same result.

How can I launch an instance of Caja with the gtk inspector?


UPDATE

Once Caja finishes loading, it appears to detach itself from the shell I'm launching it from. This may be what's causing it to lose the debug modules I'm trying to load with it.

2 Answers 2

1

Try opening a Caja instance and then typing <Ctrl> + <Shift> + D. I was able to bring up the gtk inspector doing this, as suggested by https://blog.gtk.org/2017/04/05/the-gtk-inspector/.

1
  • I happen to know, that this works. I used it for creating my theme.
    – WGRM
    Jul 21, 2021 at 16:28
0

According to the Caja man file, Caja accepts standard GTK options. Searching standard gtk options on DDG finds https://www.systutorials.com/docs/linux/man/7-gtk-options/ listing the option

--gtk-debug=FLAGS

A colon separated list of GTK+ debugging flags to set. Valid flags are objects, misc, signals, dnd, and plugsocket. The special value all enables all flags.

Running caja --gtk-debug=all in a terminal brings up a Caja instance in an interesting mode, which might be what you're looking for.

1
  • This is interesting but it doesn't make a difference for attaching the inspector.
    – Zhro
    Aug 12, 2019 at 12:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .