Is it possible to make Linux kernel completely ignore the floppy disk controller? I do not have the drive but obviously my motherboard does contain the controller. I would like to disable the /dev/fd0 device node somehow to avoid Thunar and other tools detecting it and probing it.

  • 1
    Can't you disable the controller in the BIOS?
    – Renan
    Nov 1, 2012 at 11:53
  • 1
    If not, you can always recompile the kernel with no floppy driver (assuming it's built-in and not a module now)
    – Useless
    Nov 1, 2012 at 15:54

3 Answers 3


On Ubuntu, the floppy driver is loaded as a module. You can blacklist this module so it doesn't get loaded:

echo "blacklist floppy" | sudo tee /etc/modprobe.d/blacklist-floppy.conf
sudo rmmod floppy
sudo update-initramfs -u

Immediately and upon rebooting, the floppy driver should be banished for good.

  • 3
    Shouldn't even need to reboot, it should be gone after that rmmod.
    – derobert
    Nov 1, 2012 at 17:34
  • 6
    Hence the line "immediately and upon rebooting". The point was that it works immediately, and it will also persist after a reboot, so you don't need to keep doing it.
    – Jim Paris
    Nov 1, 2012 at 18:09
  • 3
    My apologies, I read that wrong.
    – derobert
    Nov 1, 2012 at 18:12

The presence or absence of a floppy drive is something that is configured in the system's BIOS. You have to manually tell the BIOS what type of floppy you have, and it in turn tells the OS. This is because the hardware is not actually capable of being auto detected.

So you need to go into your BIOS and tell it that you have no floppy.


I ran into this problem even using a V>! Host= Windows Server 2012 Essentials. Guest = Linux Mint 14. Hardware = HP Proliant ML350, no floppy drive. Problem did not occur in any other guest.

VMware WS 9. Define Linux Mint as Ubuntu 64. Remove virtual floppy drive before installing from ISO.

Error reported = Error mounting system managed device /dev/fd0. Command line ... /media/flopp0 exited with non-zero . /dev/fd0 is not a valid block device.

/dev/fd0 was attempting a mount in fstab. /dev/fd0 existed. /media/floppy and /media/floppy exist. Removed /dev/fd0 from fstab. Remove floppy and floppy0 directories (with sudo of course).

Reboot - same error /dev/fd0 and /media/floppy were recreated.

Used the command above. Rebooted. No error.

  • 1
    This answer of yours is more like a comment on the answer of the other person than a proper answer to the question. It would be good to "relocate" it.
    – rbrito
    Nov 13, 2012 at 8:29
  • 1
    I think the answer being suggested here is to remove /dev/fd0 from /etc/fstab. I don't think that actually addresses the original question, since fstab is not entirely related to GUI environment auto-mounting.
    – jw013
    Nov 13, 2012 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.