0

My dhcp client because some openssl version mismatch.

Here is an error:

debian:~$ sudo dhclient
dhclient: /usr/local/lib/libcrypto.so.1.1: version `OPENSSL_1_1_1' not found (required by /lib/x86_64-linux-gnu/libdns-export.so.1104)

debian:~$ whereis openssl
openssl: /usr/bin/openssl.old /usr/local/bin/openssl /usr/include/openssl /opt/openssl/bin/openssl /usr/share/man/man1/openssl.1ssl.gz

debian:~$ /usr/bin/openssl.old version 
OpenSSL 1.1.1c  28 May 2019

$ /opt/openssl/bin/openssl version
OpenSSL 1.1.1c  28 May 2019

debian:~$ /usr/local/bin/openssl version
OpenSSL 1.1.0  25 Aug 2016

Is there is a way to remove OpenSSL 1.1.0 and leave the latest one?

  • Congratulations! You managed to install packages with missing dependencies... try reinstalling dhclient, openssl, and others. Don't install from source (/usr/local/bin gave you away) unless you are absolutely sure of what you are doing. Use packages where possible. – vonbrand Aug 12 '19 at 12:34
1

The manually installed OpenSSL in /usr/local has priority over the packaged one in /usr. Depending on how you installed it, there may be an easy (manual) way to remove it (like make uninstall), or you'll have to resort to deleting the various components from /usr/local/bin, /usr/local/lib, /usr/local/etc, /usr/local/share and so on one by one. Don't forget to run ldconfig (as root) when you're done.

  • Thanks for the reply. I installed openssl according to this SO's answer – slesh Aug 12 '19 at 8:10
  • Seems that I really need your help. I've uninstalled /opt/openssl/bin/openssl using make uninstall. But I don't know to to uninstall /usr/local/bin/openssl. When I run aptiture remove openssl install openssl1.1.1c-1 rather than removing it completely. – slesh Aug 13 '19 at 19:38
  • Official packages don't install files under /usr/local, that's the default location for packages installed locally from source. If you haven't got the configured source tree that installed these files (or something equivalent), you'll have to delete these files manually one-by-one (instead of simply running make uninstall). If you haven't put anything else there, this will pretty much amount to removing all files under /usr/local, since on a pure Debian system it's an empty directory hierarchy. – Ferenc Wágner Aug 13 '19 at 20:11
  • I fear that I can break my system... I just tried to relocate /usr/local/lib/libcrypto.so.1.1 into another dir and it brokes my network connection... – slesh Aug 13 '19 at 20:16
  • That's surprising, but you'd have to be much more specific than something "breaks" to get usable help. Looks like your system isn't really Debian anymore, you made significant modifications, which you should disclose as well. – Ferenc Wágner Aug 21 '19 at 7:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.