1

Updating broke Cinnamon for me. I was on 19.1 Tessa, Cinnamon edition, and updated to 19.2 through the Update Manager. Now when I boot I get the message “Cinnamon just crashed. You are currently running in Fallback Mode” and I have the option of restarting Cinnamon, but it immediately crashes again. I’ve tried with kernel versions 5.0.0.23, 5.0.0-20, and 4.15.0-55. My graphics card is an RX480.

I tried running cinammon --replace in the terminal. The output can be found here.

I tried booting into recovery mode then selecting the option to continue into a normal boot. I then got a message saying that "Your system is currently running without video hardware acceleration." However, Cinnamon is working fine. This is Mint 19.2, Cinnamon version 4.2.3, and kernel version 5.0.0-23-generic.

This is the output of running cinnamon --replace on the working Cinnamon desktop I get from booting through recovery mode. Conspicuously, the crashing version has the line cinnamon: ../src/gallium/drivers/radeonsi/si_state_viewport.c:239: si_emit_guardband: Assertion `left <= -1 && top <= -1 && right >= 1 && bottom >= 1' failed. where the working version is starting to add systrays.

Finally, I tried booting normally but selecting Cinnamon with software rendering at the login screen. It worked fine. Then I tried to restart Cinnamon and got this output with the same error message with the driver. It definitely seems like a driver issue, but I don't know how to resolve it.

Edit: this is the subject of a bug discussion on Github. It seems to have to do with the position of monitors in a multi-monitor setup.

0

I had the same issue! I guess the problem is that Mint would save the display setting every time you turn off the computer. If there is just one time you turn off the computer with the second monitor connected and then boot without the second monitor, Mint would get confused and lose track of your display setting thereafter.

Have you tried to log out and log in again? After re-login, will the gpu work normally? If so, you can then respawn a new xorg.conf (etc/X11/xorg.conf) with the command "sudo aticonfig --initial". By doing so, the gpu could make the call during boot up, instead of letting Mint do its loading-the-last-display-setting nonsense.

Though my gpu is a nvidia, I think the mechanism is the same.

Hope it helps!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.