0

I have just installed Debian 10 (Buster). It worked fine, until I did a reboot. Now it will not boot.

I re-loading installer. When I try to re-install grub, it wants me to re-partition the disk (even though this is fine). So I go into manual partitioning, and set thinks up as before (and same as Debian 8). It says I have 1MB free before 1st partition, it won't let me set the boot flag on any of my partitions.

Then I am told that the target file-system contains files that may be a problem (yes I know, I just want to get to the grub-installer). debootstrap fails (good). Select Grub-install again, am told that it depends on earlier steps, I select back. I am now in grub installer.

I given option: Enter device manually, I select it. I accept /dev/sda

I get an error: `Executing 'grub-install /dev/sda' failed. This is a fatal error.

I select continue and re-try with /dev/sda1

I now get an error it seems that this computer is configured to boot via EFI, but …

EFI is disabled (well as close to disabled as is possible: “legacy” enables, and “legacy first” selected in boot options) in bios setup. EFI dose not work: It would not boot the install media. It may have been enabled during install, but with bios-boot selected from boot menu. This system previously had Debian Jessie installed. It has also been running Buster (the one that will not boot, for a week). Last week it also did not boot (similar/same problems), but it went away. Some how it booted.

Update: problem found, now I need to find a solution

I am booted into gparted live. fdisk -l shows

  • Partition table type (Disklabel type): gpt
  • root partition type: EFI System
  • 3 or 4 blocks free at end of disk (for 2nd copy of gpt)

I got it to work

see https://unix.stackexchange.com/a/535029/4778

However it is a bit of a kludge: it warned that it was an unreliable solution. Since doing this I have noticed that grub-pc is installed, and not grub-efi… (this may be because I had to start the installer in BIOS mode. I don't know why the partition table got converted to GPT).


Hardware: Lenovo Yoga 3-11 (the yoga3 with intel graphics)

  • Buster is the most buggy Debian I've seen. Persisting to Stretch. – iBug Aug 10 at 12:52
  • When the installation finishes, it reboots the machine into the installed system. Did that work once, and then never again? When you wanted to rescue the broken installation, did you start the installer in rescue mode? – Ferenc Wágner Aug 11 at 10:04
  • Yes it worked once, then did not. Then I tried to fix. I got similar errors, but some how it booted. I thought it was fixed, but then on next re-boot it would not boot. So I booted installer → selected advanced → selected rescue mode. – ctrl-alt-delor Aug 11 at 10:51
0

I had a similar problem with Debian 9, but installed it next to a previous version.

If you also have an existing installation with grub2, you should be able to use update-grub to auto-detect the new installation, or to add a manual entry that you can insert in one of the 4?_custom files under /etc/grub.d/.

Also check that the boot and esp flags have been set on the FAT32-partition that contains the boot loader.

This is all I'm aware of on booting with UEFI/GPT.

  • What fat32 partition? And I don't know if any of this will help, I don't know if grub is installed. How can I find out? – ctrl-alt-delor Aug 10 at 19:35
0

If you're not using EFI you must have a 1MB grub boot partition on your GPT disk. (This is not /boot; it's to hold the grub boot code.)

I've reached the point where I now always include such a partition even if the system might boot with UEFI or if the disk isn't intended as a boot disk. It's easier to remember this way.

0

I managed to do it:

  • I booted gparted live,
  • mounted my root to /mnt
  • bind mounted /dev and /proc onto /mnt/dev and /mnt/proc
  • tried grub-install, it did not work, it gave a warning that it could only work by doing something that is discouraged.
  • I gave it the force option. It worked.

My guess is that this should be stable until, at least, I next try to edit the partitions. If so all is good, I have lived through many updates, and only edit the partition table of the main hard disk when doing OS updates (since virtual-box and docker I don't dual boot).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.