0

This happened to me at least once before.

What happens is, that after updating and rebooting (Fedora 30), xfdesktop and Thunar don't show removable drives anymore. Sometimes this issue seems to fix itself after rebooting, but not always.

To mount drives I usually use gnome-disks in those situations. When doing so, they appear as non-removable disks in Thunar, and are still not showing up on the desktop.

killall xfdesktop and xfdesktop --reload both don't help.

~/.config/xfce4-session/ is empty.

This doesn't seem to be an issue with a specific version of xfdesktop or Thunar, though. I have a different machine which runs the same OS and the same DE, yet, even when updating packages at the same time, to the same version, one shows the error while the other doesn't.

0

May sound a bit stupid, but did you check the options through the GUI? I had the same issue with XFCE/Thunar in MX Linux Live (non-persistent), but that was resolved somehow. One thing I did by default was check the appropriate boxes in the GUI Desktop Settings window, Icons tab in the Default Icons list. If the settings are overridden in some obscure way, maybe accidentally, GUI-based changes should take care of that.

Also make sure that the Show hidden files on the desktop checkbox is ticked/enabled, as unmounted devices may be hidden; on my desktop they appear with some opacity, which is sometimes done by file management tools to visually denote a hidden file.

  • It recently "solved itself" through an update. However given just by how often I've come across this error, I'm pretty sure it'll show up sooner or later. I'll see if I can revive this question a bit when this happens. – polemon Sep 6 '19 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.