3

I have an awesome-copycats conf and since last Arch Linux update I have no more font on the topbar widget. Every single character is a square.

That is affecting taglist, clock and so on.

Basically what is defined by:

theme.font                                      = "xos4 Terminus 9"

from theme.lua

I checked if that xos4 Terminus is still here, and that seems to be the case.

fc-list | grep Terminus 
/usr/share/fonts/misc/ter-x12b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/misc/ter-x22b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/misc/ter-x32b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/misc/ter-x18b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/misc/ter-x20b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/misc/ter-x28b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/misc/ter-x16b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/misc/ter-x14n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/misc/ter-x14b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/misc/ter-x24n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/misc/ter-x24b.pcf.gz: xos4 Terminus:style=Bold
/usr/share/fonts/misc/ter-x16n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/misc/ter-x18n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/misc/ter-x20n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/misc/ter-x28n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/misc/ter-x12n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/misc/ter-x22n.pcf.gz: xos4 Terminus:style=Regular
/usr/share/fonts/misc/ter-x32n.pcf.gz: xos4 Terminus:style=Regular

I also tried to change it by another font. But that does not make the trick.

Any idea on how I could have it work?

4
  • 1
    In my case (Gentoo Linux) Terminus fonts require bitmap fonts enabled. One way to do this is making a link from /etc/fonts/conf.avail/70-yes-bitmaps.conf to /etc/fonts/conf.d/70-yes-bitmaps.conf. I hope this helps:| There is also an alias for terminus in /etc/fonts/conf.avail/75-yes-terminus.conf which may not be necessary. – Ladon Aug 10 '19 at 5:30
  • I solved font issues with 2 steps. 1st I install gtk2fontsel and saw that some fonts where corrupted. Then I could select working one. But I still had some issue with notifications boxes. Not whole text was shown. So I update lcpz/lain which is strongly linked to awesome-copycats. – mickro Aug 13 '19 at 9:09
  • @mickro can you tell me how you updated lain? I have the same issue. – Koundinya Vajjha Aug 15 '19 at 13:51
  • I've lain linked to its github repository. So I simply git pull. And that fallen in order. – mickro Aug 21 '19 at 9:58
1

It looks like Pango, the library that Awesome WM uses to render fonts, has dropped support for bitmap fonts. I have installed the TTF version of Terminus and specified it in my theme file like so:

theme.font = "Terminus (TTF) 12"

Depending on your font rendering settings, you may need to adjust how Terminus is rendered in your .config/fontconfig/fonts.conf, but it looks like at least the Arch Linux package of Terminus TTF comes with necessary config files to disable anti-aliasing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.