4

I have problems with cursor size on one of my Xorg screens on CentOS 7. I have two screens. One runs xfce4 window manager and desktop, while another runs mwm window manager. This is a custom setup, which allows a fullscreen Motif application to run on screen with mwm, and other apps on xfce4 screen. I also have special kind of monitor for Motif app, which is 2048x2048 resolution.

The problem I have is that all except one cursors are to big on mwm, while on xfce4 they are all normal. Cursor shaped "X" on desktop background is normal size while others are oversized.

Here's a picture where an one of oversizeds cursor can be seen: enter image description here

How can I change the size of cursors on mwm screen? I have tried Xcursor.size in Xresources, but with no effect.

Here are some more pictures showing cursor sizes. enter image description here enter image description here enter image description here

Another update:

I have tried different window managers to see if cursor size is big there too. KDE, for instance, works fine. However, when I open XTerm window cursors are too big within that window. The app I use also uses Xt and Motif widgets, and also shows big cursors.

enter image description here enter image description here

  • all except one cursors are to big on mwm - I don't understand that. In what places on the screen is the cursor getting bigger? – Arkadiusz Drabczyk Aug 12 '19 at 8:16
  • All except one means that "X" shaped cursor on background is normal size. All others used in windows are bigger. I have attached some more pictures. Because I cropped an image, the last picture with "X" shaped cursor also seems to be too big, but it is not. – nobody Aug 12 '19 at 10:44
  • OK, I see. I've just tried mwm inside Xephyr and I don't have that problem so I think it's your local config. KDE, for instance, works fine. However, when I open XTerm window cursors are too big within that window. - ok, so cursor is too big in KDE as well and not only in mwm? – Arkadiusz Drabczyk Aug 12 '19 at 14:08
  • Yes. I know it is my local config, and I am looking for a solution for the problem in my local config. I am trying to figure out why these big cursors are being used on 2048x2048 screen with mwm (and motif (or Xlib) based applications. – nobody Aug 13 '19 at 5:14
1

I have found a solution that works for me.

At first I inspected sources for mwm, libXm, libX11 to see how could I make programs use smaller cursors. I tried some changes, but realized it would require to much work, recompiling, etc.

Than I renamed/removed /usr/share/icons/Adwaita/cursors directory. When X did not find oversized cursors installed by adwaita-cursor-theme package any more, the only remaining ones are not as beautiful as Adwaita cursors but are at least of the right size.

I believe adwaita cursors are required by essential packages, so I cannot afford to delete package adwaita-cursor-theme. I have two options:

  1. Remove cursors directory and use cursors not from this theme. Remaining cursors are probably from cursor font, which is provided with Xorg. They have only two colors, while Adwaita cursors have more colors and shadows.
  2. Resize Adwaita cursors, which should easily be done with Gimp, for instance.

Final solution: I downloaded adwaita theme sources and created new cursors. There are files *.in where cursor sizes are specified. I edited these files to remove large size cursors and created new cursors with make.sh, which basically calls xcursorgen for each cursor. I put these cursors in /usr/share/icons/Adwaita/cursors and now I have the cursors sized as I want.

  • I found compiling against open Motif to be relatively trouble-free. – dotbit Dec 10 '19 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.