2

I cannot manage to load the tun module in my Arch Linux box. I'm trying to connect with openvpn, but the log says

nm-openvpn[6662]: Note: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)

lsmod | grep tun

returns nothing.

If I run

sudo modprobe tun

it returns failure, but no error message, and lsmod still has no tun. The module seems to exist, as there is a tun.ko.gz in /lib/modules/.......

I really don't know what else to try.

3
  • Try an insmod on the path of the tun.ko and look at the dmesg output. Oct 31, 2012 at 21:58
  • What happens if you insmod the module manually?
    – Renan
    Oct 31, 2012 at 21:58
  • How do I do that? I tried insmod /path/to/tun.ko.gz, I got "Invalid module format", I unzipped it and tried again and got the same
    – rabipelais
    Oct 31, 2012 at 22:05

1 Answer 1

1

Contact your VPS provider and ask them to enable it. Many OpenVZ-based VPS providers disable TUN/TAP unless specifically requested by the customer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .