1

I upgraded from Debian 9 to Debian 10.

Problems I had during the upgrade:

  • I couldn't use dolphin during and after the upgrade (it said "Unable to create io-slave. klauncher said: Error loading '/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kio/file.so'."). I did not know that I had to restart before it would work again so I ran killall plasmashell, kstart plasmashell and dbus-launch dolphin after which it worked again.
  • Apparently I didn't have enough disk space for the upgrade on my SSD partition (it's not a particularly small partition, I had some GBs free and did not get a warning). This is why I had to run sudo apt-get upgrade and sudo apt-get dist-upgrade multiple times as they didn't run through completely at once. I ran upgrade first and again after a partial dist-upgrade. I think not enough storage space on my SSD OS-partition is also why I had to run sudo dpkg --configure -a and sudo apt --fix-broken install. I also ran sudo rm -r /var/cache/apt/archives/* to free up more storage space.

Problems I'm having now:

  • The Plasma desktop looks too bright now. It's unlikely to be a redesign/appearance issue. It's like a layer of brightness above everything and windows now I have an intense shadow on bright backgrounds and glow on dark backgrounds. For example the black of the console isn't really black anymore. It's really bad even though it might not look like that in the screenshot below. I already tried changing my monitor brightness settings and the gamma settings (1.0). I'm using the Dark Breeze theme.
    The one thing that has helped so far is setting the HDMI Black Level from Normal to Low in the options of my monitor. However the intense glow around windows still exists, the colorfulness/chroma/saturation has changed and is a bit too high I'd say even when changing the monitor's contrast and color-saturations (I'm not really sure about that one, it might even partially look better after adjustments) and I doubt it's intended for people to change this default monitor setting to make it appear normal (I guess many monitors don't have this setting) and I don't know how to check whether the appearance is configured correctly now.
    I noticed the HDMI Black Level setting of my monitor only while writing this and decided to post anyway because I'd still like to change the window-glowing, the fix doesn't seem like the solution-as-intended and maybe somebody has the same problem.
    enter image description here
    For comparison this is how it looked before:
    enter image description here
    You can't really see most of the brightness-increase in it though: maybe I'll take pictures of my monitor with the setting disabled and enabled later.

  • Icons are missing in the task bar. A few of them show up now.
    enter image description here

  • Favorites are missing. Now it shows 5 entries which are probably the default ones.

These two problems have to do with this file: ~/.config/plasma-org.kde.plasma.desktop-appletsrc. The fix described at rglinuxtech.com/?p=1626 (deleting [Configuration][General] entries and renaming [Configuration] to [Configuration][General]) didn't help much. The icons show in ~/.local/share/applications/ but not in ~/.local/share/plasma_icons/. I already tried kbuildsycoca5. The file still contains all my favorites but Plasma does not load them. I can still add favorites and add apps to the panel (widget).
When I add one of the apps to the panel that are already present on it but whose icons doesn't show and then make the other entry in plasma-org.kde.plasma.desktop-appletsrc look exactly the same the newly added app icon shows but the old one doesn't. This is because when I add it anew it adds a new file to ~/.local/share/plasma_icons/ while the other one's icon is broken because in the file it says "Icon=unknown" (the only difference is that the new entry links to the new (1) file):
enter image description here
Also when I completely delete the plasma-org.kde.plasma.desktop-appletsrc file so it gets rebuild I get the old wallpaper and not the new Debian 10 one.

  • I'm not sure how to fully validate that everything was upgraded, installed and configured correctly: is there another way for validating the complete upgrade beyond these commands: uname -a hostnamectl sudo apt search '~i(!~ODebian)' dpkg -C apt-mark showhold?

Do bug reports for these problems exist? What's the recommended way to fix these Plasma/appearance issues?


Other new issues I have noticed so far:

  • One of my disks is now making noise from time to time that it didn't before. I'm checking the health of them with tools like gnome-disk-utility. Gnome-disk-utility says all disks are OK but one (not the SSD) has one bad sector. I could not run a SMART self-test on this particular disk so far as it returns "GNOME-Disks-WARNING **: Error getting ATA SMART information: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: SMART data not collected (udisks-error-quark, 0)" and "sk_disk_smart_self_test: Input/output error (udisks-error-quark, 0)" in a dialog window. I don't think I ever had any of my current disks make these sounds. It could be due to some earlier backup-process.
    • Fans and power supply are making noise now too. The power supply is the loudest. Maybe I mistakenly thought it was an HDD when it was the PSU. It wasn't so loud immediately after upgrade: the PSU now makes spinning-sounds and it sounds like it'll fail any time. Had to replace them for good anyway. Update: I think the fans are okay now. Everything is cooled according to lm-sensors and now they aren't loud. This problem could also be due to the spectre-meltdown patch. Not sure how to find the cause for the PSU making this noise. It's strange that this never happened before but soon after the update and spectre patch.
  • Running sudo kate returns "Executing Kate with sudo is not possible due to unfixable security vulnerabilities". I think I had this before but I don't know when and why and what I did about it. I prefer kate over nano. Now you can use kate to open write-protected files and get prompted for the password when saving so this is mostly resolved. But you can't open read-protected files such as syslog and e.g. cat /var/log/syslog is missing proper kate/texteditor-features like highlighting etc.

Resolved:

  • When booting it displays: "TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x.. (or later)." before asking for my disk password. It did not display this error before. I fixed this by installing intel-microcode. I was not notified about this before, recently installed spectre-meltdown-checker and didn't have non-free enabled in the sources.list.
  • When migrating from iptables to nftables as described nftables doesn't work when iptables rules for Docker are included. It also didn't enable the nftables-rules at every boot: for this one needs to first write the contents of ruleset.nft generated via iptables-nftables-compat to /etc/nftables.conf before running systemctl enable nftables.

Had the problems with the icons and favorites on another machine I upgraded too. Favorites are still there with icons but some of them are missing and the tray icons look the same - so that seems to be a bug in KDE. However I did not have these appearance issues with the brightness and colors and the border-glow is not too visible.

0

I have created a bug report for the problems after upgrade (not the two during upgrade) here: https://bugs.kde.org/show_bug.cgi?id=420561

The improvised solution to this is to just readd the favorites and panel applications and to calibrate monitor settings as described above (setting HDMI Black Level from Normal to Low etc). However, calibrating monitor setting doesn't make it look as good as before - there are still those strange window-glows and -shadows.

I recently tried it with my old graphics card instead of CPU-only and it's not too bright and "glowy" when using the graphics card. Strangely the graphics performance seems to be at least as bad as with CPU-only when using the nouveau driver and does have glitches where it shows green space across the screen which is why I removed it again. However, when using it I could change the HDMI Black Level from Low back to Normal. It could also be a bug in Debian but I only had this after upgrading from Debian9 to 10.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.