In this question I asked how to prevent a media failure from halting the system boot process. However, I got two suggestions for /etc/fstab options

  • nobootwait
  • nofail

What is the difference between the two?

5 Answers 5


Firstly nofail allows the boot sequence to continue even if the drive fails to mount.

This is what fstab(5) says about nobootwait

The mountall(8) program that mounts filesystem during boot also recognises additional options that the ordinary mount(8) tool does not. These are:

  • bootwait which can be applied to remote filesystems mounted outside of /usr or /var, without which mountall(8) would not hold up the boot for these;

  • nobootwait which can be applied to non-remote filesystems to explicitly instruct mountall(8) not to hold up the boot for them;

  • optional which causes the entry to be ignored if the filesystem type is not known at boot time; and

  • showthrough which permits a mountpoint to be mounted before its parent mountpoint (this latter should be used carefully, as it can cause boot hangs).

fstab(5) has this to say about nofail

nofail do not report errors for this device if it does not exist.

  • 6
    Note that mountall and those options are ubuntu (and its derivatives) specific (and only relatively recent versions where upstart and that mountall was introduced. Nov 30, 2012 at 22:36
  • 18
    nobootwait is no longer a valid option in Ubuntu 16.04 (as of 2016-07-10 testing Mythbuntu install/live-DVD).
    – Kingsley
    Jul 12, 2016 at 2:42
  • 2
    External devices that are to be mounted when present but ignored if absent may require the nofail option. This prevents errors being reported at boot.
    – endolith
    Sep 23, 2016 at 14:14
  • 2
    i say quite explicitly fstab(5). So man 5 fstab Jul 8, 2017 at 4:32
  • 1
    I see, that's Ubuntu 14 (Trusty). Thank you @EvanCarroll. Just to confirm what Kingsley said above bootwait/nobootwait is no longer supported on Ubuntu 16 LTS. Only nofail.
    – ILIV
    Dec 20, 2017 at 7:00

Since this old question has a high Google rating, I'll mention that since "nobootwait" doesn't work with systemd, the correct method is to set a short timeout of, say, 9 seconds with "x-systemd.device-timeout".


/dev/sda2  /mnt/other  auto  defaults,nofail,x-systemd.device-timeout=9  0  2

(Edit: I've increased the timeout from 3s to 9s because it seems that Ubuntu occasionally does a quick filesystem-check on bootup that can last longer than 3s.)


As mentioned by Stéphane, nobootwait is limited to ubuntu+derivatives.

Nofail will keep trying to mount the drive as cjm pointed out, however, the boot process will continue after the mount reaches timeout. If you don't expect the drive to be there regularly as to warrant the extra 90 seconds or so bootup when it's absent, don't automount it in fstab.

(P.S. I put this as cjm's answer sounds as if the system will ultimately fail to boot).


This article seems to explain the difference well

mountall tries to automount all entries from fstab that have the defaults or auto mount options. It will halt the boot process if such entries cannot be mounted, except when the mount option nobootwait is given.

fsck tries to do a filesystem check on all entries from fstab that have the sixth field set to 1 or 2. Non-critical drives typically have this field set to 2. It will halt the boot process if such filesystems cannot be checked, except when the mount option nofail is given.

Disclaimer: I am not a fstab expert and cannot guarantee/verify the above information to be true. All credits belong to the author of that article.


In my case, below are the mount options added into the ubuntu-20.4 /etc/fstab file. I was able to mount without any error.

UUID=297e42c4-436d-4218-953e-f2681ff7df8c /raid  ext4    errors=remount-ro,nofail  0   1   

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .