1

I tried to install GFORTRAN_7 on f29 since I needed libfortran.so.4 for a program.

What I did

I've found the rmp file (libgfortran4-7.3.1-alt9.x86_64.rpm), downloaded it and tried to install it. I had to install some perquisite packages. The first one was libgcc1-8.3.1-alt5.x86_64.rpm but when I tried to install it I got a dependency issue. Then I tried to extract the contents using the rpm2cpio command. A folder named lib64 was created and in it the libgcc_s.so.1 file was saved.

I manually copied this file to /usr/lib64 and then chaos happened! The laptop rebooted instantly and the login page appeared within a couple of seconds (normally it takes about 20 seconds to do a reboot). I logged in and then there was a strange issue with the graphics.

Until then I was using cinammon (with the navigation on the top of the screen) and suddenly another navigation bar, different from cinammon appeared on the bottom. After a few minutes I got a crash in cinammon and a pop-up window asked me if I wanted to restart cinammon now. I selected no and then I could no longer do anything on the laptop. So I manually turned off the laptop.

What happened

When I tried to turn it back on, it didn't boot. Instead I had the following error concerning a Bad RIP value and a Kernel Panic

https://imgur.com/KVkawPp.png

I tried to boot in previous fedora versions that I have installed and in the rescue mode but I get the same issue.

I then created a live f30 usb and from there I can have access to the files.

I rebooted and then I got a similar error, but shorter in this case

https://imgur.com/mcixgtc.png

In another reboot the error is similar to the first one

https://imgur.com/7x5qn0F.png

Trying to debug

From the live usb, I tried to see an error in the journal by typing journalctl -r -p err but I am not sure if it reads the proper journal (i.e. the one that I had f29 installed).

https://pastebin.com/dJNv9mbB

I don't know if it's related, but I tried to see the log files of rpm, in order to give you more details and I've noticed that in the /var/lib/rpm/ directory there are the following files which were created today. The time probably it's not correct, but I report it just in case it is important.

-rw-r--r--. 1 root root    311296 Aug  8 04:48 __db.001
-rw-r--r--. 1 root root     90112 Aug  8 04:48 __db.002
-rw-r--r--. 1 root root   1318912 Aug  8 04:48 __db.003

I also had a look at /var/log/messages and there is an entry concerning the libgcc_s.so.1 file.

Aug 8 10:51:33 pcen35240 tracker-extract[14686]: /usr/libexec/tracker-extract: error while loading shared libraries: libgcc_s.so.1: cannot open shared object file: No such file or directory

However I am able to see the file

[liveuser@localhost-live b0276d9d-2767-4839-9085-9cc2c27e68ca]$ ls -lhtr lib/libgcc_s.so.1
lrwxrwxrwx. 1 root root 24 Feb 23 15:10 lib/libgcc_s.so.1 -> libgcc_s-8-20190223.so.1
[liveuser@localhost-live b0276d9d-2767-4839-9085-9cc2c27e68ca]$ ls -lhtr lib64/libgcc_s.so.1
lrwxrwxrwx. 1 root root 24 Feb 23 15:27 lib64/libgcc_s.so.1 -> libgcc_s-8-20190223.so.1
[liveuser@localhost-live b0276d9d-2767-4839-9085-9cc2c27e68ca]$ ls -lhtr usr/lib64/libgcc_s.so.1
lrwxrwxrwx. 1 root root 24 Feb 23 15:27 usr/lib64/libgcc_s.so.1 -> libgcc_s-8-20190223.so.1
[liveuser@localhost-live b0276d9d-2767-4839-9085-9cc2c27e68ca]$ ls -lhtr usr/lib/libgcc_s.so.1
lrwxrwxrwx. 1 root root 24 Feb 23 15:10 usr/lib/libgcc_s.so.1 -> libgcc_s-8-20190223.so.1
[liveuser@localhost-live b0276d9d-2767-4839-9085-9cc2c27e68ca]

I've pasted a part of this file from a time reference a bit before this issue in case someone has a clue (The full file can be found here https://cernbox.cern.ch/index.php/s/vpi89mDmzgli0Lq)

https://pastebin.com/3ZF1DHd6


Any idea on how to solve this, preferably without having to install from scratch the OS ?

*Note that at the moment I can only have access to my system through a f30 live usb.

  • First things first, do not do that: do not replace manually libraries. Since you are at CERN, you should know why and how they make SLC (SLC) and the associated tools for you to do your job. So, even if it's a .rpm do not install. Restore the library you messed up with and remove the package you've installed, all should be good. And remember that packages managers are here for a reason. If that was a process you got into in order to do something else, feel free to ask another question so we can help you "safely". ;) – Paradox Aug 11 at 14:31
2

You need to reinstall the broken / overwritten library files in /usr/lib64 (and possibly, other places.

  1. Boot a live system from USB, as you have already done.
  2. Mount the broken root file system, let's say, at /mnt/fedora .
  3. Identify the broken files (or use ls, or remember which ones you overwrote).
  4. Identify the package names of these files - at least, this includes libgcc.
  5. Re-install these inside the /mnt/fedora path: yum --installroot=/mnt/fedora reinstall libgcc (...)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.