1

I have the latest blackarch ISO (2019). I have live-booted it on a 64-GB USB. The Live-Boot works perfectly. However, if I install it in my HDD, It boots in the GRUB Menu. Here is the steps I followed: I used blackarch-install command. Once I reached the query saying install with windows/other OS?(y/n)? I put in y (though I tried with n too). Then opens the partition menu. The partitions are as follows:

/dev/sda1:HPFS (where in my Windows resides)
/dev/sda2: (500M) Linux
/dev/sda3: (16G) Linux Swap/Solaris
/dev/sda4: (128G) Linux

Proceeding, I set the boot partition as /dev/sda2 and root as /dev/sda3 with both filesystems ext4 (I even tried with ext3 and ext2 for both and btrfs for root partition) When I write this partition table and install it, the installer ends without any error even the grub-install returns no error

However, when it tells me to reboot, on reboot, it goes to the GRUB menu. surprisingly, after installation, no initrd file shows up in the / or the /boot directory, though an initramfs is there (which when used dumps the kernel)

What am I doing wrong during the Installation?

solutions here don't work :(

  • 1
    Apparently blackarch-install does not support installation on a machine with UEFI firmware, which is the norm today. If you have UEFI firmware, you may be better off trying to install Arch Linux first and then install BalckArch on top of that, as described in the guide. – Johan Myréen Aug 7 at 17:17
  • But my disk has Legacy support enabled. And the partition scheme is also MBR – user324028 Aug 7 at 17:20
  • Ok, I guess that's not the fault then. I said "if"... – Johan Myréen Aug 7 at 17:25
  • 1
    @JohanMyréen There is no /boot/efi partition, so it's not EFI . – Ned64 Aug 7 at 17:28
  • Oh sorry. But can you please help me with this? This is really getting on my nerves. – user324028 Aug 7 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy