1

Formatted USB using mkfs.ext4 /dev/sdb on Ubuntu OS. SanDisk Ultra drive. USB shows as mounted.

After I click the usb-flash icon in desktop manager, the only thing that shows up is lost&found directory, locked. I mounted as "rw" as well. I wanted to format the entire usb so I used "sdb" instead of "sdb1". Maybe this was a mistake.

How can I paste files to this USB disk?

mount | grep sdb (using sdb b/c recognized as 'disk'):

/dev/sdb on /media/whoami/538688e2-9342-4344-86a9-02c7b14d7b67 type ext4 (rw,nosuid,nodev,relative,uhelper=udisks2)
/dev/sdb on /media type ext4 (rw,relative)

There seems to be a difference between formatting from... 'right-click' on USB in desktop manager, "format", ext4, VERSUS, "sudo mkfs.ext4 /dev/sdb". Was able to add files after formatting from desktop manager, not mkfs.ext4

  • The lost+found directory is to be expected. How did you mount the device? What happens when you try to copy files to it? Have you checked permissions to ensure you've got write permission to the filesystem? – roaima Aug 7 '19 at 14:40
  • I mounted as "rw" as well as just clicking the icon file manager. Copy to it: paste option grayed out. How check permissions? Thanks. – hddfsck777 Aug 7 '19 at 15:20
  • I have reformatted it to FAT and it I can paste, though the speed is very, very slow now. For a 3.0 it went as low as 500 kb/ sec and now up to 3mbps. Should be closer to 15mbps like my other SanDisk 3.0. Maybe reformatting ruined the speed factor. But still wondering why didn't work when formatted to ext4. Had same problem years past. Once put in ext4, can't paste to it. Thanks. – hddfsck777 Aug 7 '19 at 15:27
  • For troubleshooting purposes only, please eject the drive after reformatting it, then reinsert and mount. If that does not resolve the issue, please eject the drive, remove it, reboot the system, reinsert and remount it. Please advise results by clicking edit and adding results to question; instead of using Add Comment, please use edit. – K7AAY Aug 7 '19 at 15:44
  • Please add the output of mount | grep sdb1 and ls -ld $(mount | awk '/sdb1/{print $3}') to your question. – roaima Aug 7 '19 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.