1

I have a shell script /usr/local/bin/myrofi.sh which contains:

#!/bin/sh

/usr/bin/rofi -run-list-command ". /usr/local/bin/get_aliases.sh" -run-command "/usr/bin/zsh -i -c '{cmd}'" -show run

when I run this script from terminal it works perfectly, but when I run this from GNOME keyboard shortcut like:

enter image description here

then the system becomes unresponsive and it hangs the system. Then I will have to switch to login shell then run killall rofi to get back my normal system.

My system have Arch linux with Gnome window manager.

1

You should add the full path of the script, i.e /usr/local/bin/myrofi.sh, in the "Command" input field to be able to run it using a shortcut.

  • 1
    No I have tried it, doesn't work. That GNOME keyboard shortcut is creating problem because of -i option in /usr/bin/zsh -i -c '{cmd}'. I switched to xbindkeys and it works perfectly. – Ritesh Sahu Aug 7 '19 at 4:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.