0

So this is kind of strange. I was trying to put a screenshot into my Videos/ directory, and while trying to cd where I wanted to go, I was getting I/O errors. For context, I have a storage drive mounted to Videos/, and my uptime at the time of this incident was:

$ uptime
 07:26:36 up 88 days, 14:03,  3 users,  load average: 1.21, 1.18, 1.24

My first assumption was that the drive went bad, so I used mount to figure out which device file was mapped to the drive so I could unmount and remount it to see if that would temporarily solve the problem. But the system told me that no such device exists. So I ls /dev | grep sd and to my surprise, /dev/sdb* had indeed disappeared.

I had a hunch and tried mounting the others. Namely, sdc1 and sdd1; sure enough, the latter had my Videos/ directory and it seems to be working without issues.

Somehow, the partition migrated from sdb1 to sdd1 without any input from me.

Why would the kernel do that? Does this indicate a problem with the drive? Kernel bug? Kernel feature? Does Linux tend to remap drives when a hardware fault occurs?

5
  • What does dmesg say? Aug 6, 2019 at 13:59
  • Here's a small excerpt from the end of dmesg | grep sdb: pastebin.com/raw/HQAEkW2U Aug 6, 2019 at 15:17
  • Man, this thread is dead. What's going on? Aug 9, 2019 at 15:06
  • Nothing, man. I don't answer for your question. What are the results of research you did to solve your problem? Aug 9, 2019 at 17:58
  • @arkadiusz it's not an active problem for me, actually. Just curious as to why a storage device would get mapped to another /dev/sd* file when no interruption has seemingly occurred. As for what I've tried, I googled around but didn't find anything. In terms of IT issues, I seem to always get the weird ones. Like cueball from xkcd. Aug 9, 2019 at 20:03

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.