0

I am trying to kill a du -mh command that has been stuck running for 18 hours. I have tried many kill signals kill -15, kill -2, kill -9 as root but with no luck. Are there any other techniques to kill this process?

Note this is in R running state, yet it does not appear to be responding to my kill signals.

Screenshot of top command

 ps -Z 31806
 LABEL                             PID TTY      STAT   TIME COMMAND
 unconfined                      31806 ?        RN   1137:41 du
  • You can't kill a zombie, it's already dead. I have no idea what those many SE answers are talking about. You're probably rather thinking of processes stuck in an uninterruptible sleep (D, not R state). In your case: maybe you don't have permission to kill it? Try strace -e trace=kill kill PID, and if that shows that the kill() is successful, attach to the df process with strace -p PID, kill it and see how it's reacting to the signal. – mosvy Aug 6 at 11:11
  • @mosvy strace -e trace=kill kill PID returns exit code 0, and strace -p PID shows attached, but no output following kill, kill -9 command – UnixUser Aug 6 at 11:18
  • @mosvy you're right, I've removed the mention of zombie state from my question. – UnixUser Aug 6 at 11:26
  • 1
    Which means that it cannot attach it (strace succeeds because it uses PTRACE_SEIZE which doesn't stop the process). This may be some kind of kernel bug -- also see this old question. – mosvy Aug 6 at 12:58
  • 1
    do/did you have any NFS mounts on that VM? If so, see nfs(5) and read the info on the soft and hard mount options (which control timeout & retry behaviour, effectively giving you a choice between hangs like this or the risk of data corruption). I ask because I've seen hangs on df or du many times over the years when an NFS server doesn't respond to an NFS client. – cas Aug 6 at 23:38
-1

You could use :

kill -kill PID

This is very common command for force kill PID.

  • short / friendly name for kill -9 PID which I have already tried – UnixUser Aug 6 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.