0

I'm setting up a new Manjaro install on my laptop (Dell Inspiron 7567) with NVIDIA Optimus, and I've run into an issue with my monitor configuration.

When there is a monitor connected to my laptop's HDMI port, everything works fine. However, if I disable the HDMI port using xrandr --output HDMI-0 --off, or just physically disconnect the HDMI cable, the remaining internal display is unusably laggy.

All of my windows (I'm using Openbox) only update about once every 10 seconds. The mouse cursor remains perfectly smooth though, and the rest of the computer keeps working fine; I can execute commands and they execute immediately (though I can't see the results until the monitor next refreshes) and my Spotify music continues playing.

(Update: The issue only seems to happen on Openbox. i3 works fine when disabling HDMI.)

As soon as I reconnect the HDMI cable or re-enable that output, everything goes back to normal and is usable again.

Since it may well be relevant, my laptop's Optimus graphics are internally connected in such a way that the NVIDIA graphics card is directly wired to the HDMI port.

Why could this be happening?

My /etc/X11/xorg.conf (partially generated by nvidia-xconfig):

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    Option "AccelMethod" "none"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

I'm using the 430.26 proprietary NVIDIA drivers (acquired by mhwd through the video-nvidia configuration). Note that I am not using Bumblebee or a PRIME switcher.

My NVIDIA X Server Settings monitor configuration (the AOC monitor is my external HDMI one, the PRIME one is the internal monitor):

enter image description here

1

It looks like the issue was caused by Compton - disabling this has resolved the issue. (This would also explain why i3 didn't have the issue, as Compton is launched by my Openbox init script.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.