I using Arch Linux with XFCE/XFWM4. The default FM is very lightweight thunar, but I installed dolphin for some more functionality.

I was studying about large files and creating some 2 gigs of files on my system. I suddenly saw my system is going wild where baloo_file_extractor uses 3.1 GiB RAM! I suddenly killed it.

But every time I create a big file, I see baloo_file_extractor uses up all of my RAM and start consuming swap again and again.

On the other hand, I haven't used dolphin for weeks now. Why does it daemonize baloo when dolphin is not in use?

Apart from uninstalling baloo, baloo_widgets and dolphin file manager, is there any other way to prevent that from happening again?

1 Answer 1


Run balooctl disable. That'll turn off baloo and you won't need to uninstall anything.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .