3

I have just installed the AMD version of Debian 10 on a Dell Inspiron with an AMD processor. I selected Gnome and KDE as the desktop systems with Gnome as the default. When it starts up, it hangs indefinitely on "Resuming from hibernation" just after

Hostname Service
Gnome Display Manager

I tried to follow the solution given here. That is, I logged into the command terminal as root and entered.

bash -c "echo -e 10 > /proc/sys/vm/swappiness"
bash -c "echo 'vm.swappiness = 15' >> /etc/sysctl.conf"
reboot

I still got

Hostname Service
Gnome Display Manager
Resuming from hibernation

and it hung indefinitely.

Edit: The image, that I burned onto the installation disk is debian-10.0.0-amd64-netinst.iso

Output from lscpu

Architecture: x86_64
CPU op_modes: 32-bit, 64-bit
Byte Order: Little Endian
Addresses Sizes: 48 bit physical, 48 bits virtual
CPUs: 2
Online CPUs List: 0,1
Threads per Core: 1
Cores Per Socket: 2
Sockets: 1
Numa Nodes: 1
Vendor ID: Authentic AMD
CPU Family: 16
Model: 6
Model Name: AMD Athlon(tm) II x2 250 Processor
Stepping: 3
CPU MHz: 800.00
CPU max MHz: 3000.00
CPU Min MHz: 800.00
Bogo MIPS: 6000.48
Virtualization: AMD-V
L1d cache: 64K
L1i cache: 64K
L2 cache 1024 K
NUMA node 0 CPUs: 0,1
  • What is the "AMD version of Ubuntu 10"? There's no AMD version of Ubuntu (or any other OS) and the last versions of Ubuntu that started with a 10 are from 2010. You originally had Debian in your title, which I removed since you then talk about Ubuntu, but please edit and clarify what system you actually have installed. Also, please tell us if this happens if you don't hibernate. Force shutdown the system, reboot and tell us if it boots OK. – terdon Aug 4 '19 at 13:14
  • Oops. Sorry. I meant to say Debian. I have Ubuntu on another system. My mistake and I really appreciate your pointing it out. This happens when I am booting up. I cannot boot to the Desktop because of this problem. I can only boot to the command line. I do not know how to avoid the hibernate. This happens every time I reboot. Thanks, – OtagoHarbour Aug 4 '19 at 13:22
  • Thanks for the edit but you still have the AMD version which doesn't mean anything. And if you can actually boot, please edit and mention that. You say it hangs indefinitely. That means it never finishes booting. The more detail you give, the better the chances of getting an answer. – terdon Aug 4 '19 at 13:27
  • @terdon Sorry about my slow reply. I have updated my question with details about the processor and ISO file. Thanks, – OtagoHarbour Aug 4 '19 at 18:55
2

I may have had the same problem, getting a message about resuming from hibernation then freezes up.

My problem was caused by an earlier error in the startup. My video card driver was not loading. The message about resuming from hibernation was just the last message before it tried to start the gui. It could not start the x-windows due to the video issue.

I installed without kde/gnome, then added the non-free to the sources list, then was able to install firmware-linux-nonfree package which included my video card driver.

Once I did that I just installed the kde-full and gnome packages using apt install.

Check your messages during startup to make sure you are not having the same problem. May be the same issue.

| improve this answer | |
0

I had the same problem.

What was causing it for me was 0 disk space, because for some reason some of my log files in /var/log were massive. I emptied them with sudo >filename.

You can check if low disk space is your issue with df -h.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.