0

So I have a dell laptop. I had a Windows 10 + ubuntu 16 laptop. It had some problems with booting up. So, I got rid of ubuntu (went to gparted live, wiped the partitions of root, swap and home, there was no other partition; ie /boot was on root itself not a seperate partition). In order to use gparted live I had to change from uefi to legacy mode. Now, I want to install ubuntu again. So I followed the same steps as before. I used yumi to burn ubuntu iso on the flash drive. The laptop still uses legacy boot not uefi. Now, when I turned the laptop on (with the flash drive plugged), everything went smooth. It allowed me to go to the 'try ubuntu 18' option which I had burned on the flash drive using yumi. I installed ubuntu using it. However, when I restart, booting fails. Silly me, I didn't realize that now the grubloader will be looking at the wrong partition(something that doesn't really exist anymore). Now the funny thing is, when I plug in the yumi flash drive, I get 2 options, Default one(using first HDD) and the yumi one. The first time I used it, I chose the yumi option. Now, I can choose the first default option(using HDD) and it directly takes me to ubuntu 18! But I don't want to do 'plug in usb every time I turn on the laptop' thing. I just want to tell the grubloader: "hey man you're looking at the wrong place for booting, the ubuntu root partition you are looking at doesn't exist anymore, look at the new ubuntu 18 root partition." I know I'm pretty much a noob here. Can anyone help me?

PS 1. Windows works fine. I just need to press f12 and it will take me to a one time boot menu screen where I can choose windows boot manager. On this same screen there is a ubuntu option too. But it goes to a bash-like grub, obviously coz it is looking for the root partition in the wrong place. 2. Changing to uefi mode doesn't do any good. 3. tried something called boot-repair. Used 'recommended repair', but problem still the same. They gave me this link though: http://paste.ubuntu.com/p/c28tRKYzvc/ I don't understand anything it says :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.