I have a Intel N2800 motherboard with the PoverVR Cedar Trail GPU. It seemed that it was not possible to make it work other than using some meego kernel patch that works on a specific kernel version. Even the graphical part of the installer did not boot up.

To fix this issue I bought a Club 3D PCI-E x1 Nvidia GT-610 graphics card. With this card I was able to install the OS, but still can't get it to work.

With the nouveau driver that comes with the F17, the booting gets stuck at the "F" logo.

With kmod-nvidia drivers I got to the login screen, but it freezes there.

When I installed the nvidia proprietary driver and used nouveau.modeset=0 on the kernel command line to disable the nouveau driver it got stuck at booting after the text messages go past. After the text messages there is a black screen with the white "text cursor" in the top left corner. Every once in a while the screen blinks and show the text boot log that is presumably "below" the black screen.

I read that more than one fedora user has resolved this by removing xorg.conf. I tried that too, but it didn't work either. After removing the file it gets stuck on the "F" logo, with yellow stripes and other "artifacts".

The motherboard has only a single short x1 pci-e bus connector, so there are not that many other cards that can be tried.

There is also a slight possibility of a mb failure, as the USB's seem to get sometimes unresponsive at random.

Is there anything software related I could try?


Looking around I discovered that this CPU's graphic card is not supported by Linux, and it seems unlikely there will be support soon (intel won't/can't publish a driver, reverse engineering is slow and not very high priority).


I bought a intel D2700 atom board, specs looked nice I thought. cpu apparently 64bit capable. But turns out that 64bit is not supported by any graphics firmware for that chip.

Conclusions I made. Great board for a cheap 64bit server, or a workstation where you don't care about graphics (eg for an embedded application).

Things you could try for the onboard graphics: - use 32bit install (in case you are not already) - search for a patched kernel to see if that works for you. - See if another distro such as ubuntu works (eg use a livecd)

Things you could try for the nvidia graphics, try some of the older driver versions, those may not directly support the card but may have generic support for nvidia tech that will get you started. Else direct support was added in release 295, see http://www.nvidia.com/object/linux-display-ia32-295.53-driver.html),

For the USB issue, you may be using a compact power supply? Which can be a source of all sorts of weirdness. Try a bigger one (300W+) to see if that helps anything. It may also sort some nvdia card things too if that helps.

  • AFAIU, there are no open drivers for that GPU at all. – vonbrand Feb 25 '13 at 13:42
  • There may be no native ones, correct. Generic ones may work (eg vesa, fb etc) – Glenn Feb 26 '13 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.