2

I am using Fedora 31 testing release, downloaded from this site: 北京在线数据服务 Capital Online Date Service Mirrors and successfully installed a server(It may not be online) with the Fedora-Server-netinst-x86_64-Rawhide-20190729.n.0.iso file. Now I am trying to install gnome on the server, but gdm had dependencies problem (log at the botton), so I chose lightdm instead. But after installing it using the command sudo dnf install lightdm to install it and processing sudo systemctl enable lightdm.service to enable it, it didn't work (see below). In addition, the installing progress and the enabling progress did not have any error or warnings.

At first, I typed startlightdm which turns out to be an unknown command. Then, I tried lightdm. But it said that I required some authentication to do so or else you need to use the --test-mode flag. So then I tried sudo lightdm which worked, but didn't do anything at all! At last, I tried dropping the sudo and adding an --test-mode flag, which did not work either. Do you have any solutions?

Log while trying to install gdm: I'm chinese, translation is after any chinese character.

[zhc@localhost ~]$ sudo dnf install gdm
[sudo] zhc 的密码(Password):
Fedora - Modular Rawhide - Developmental packages for the next Fedora release                   8.0 kB/s | 6.7 kB     00:00    
Fedora - Rawhide - Developmental packages for the next Fedora release                           6.6 kB/s | 4.8 kB     00:00    
错误(error):
 问题(problem): conflicting requests
  - package gdm-1:3.32.0-4.fc31.i686 requires gnome-shell, but none of the providers can be installed
  - package gdm-1:3.32.0-4.fc31.x86_64 requires gnome-shell, but none of the providers can be installed
  - package gnome-shell-3.33.4-1.fc31.x86_64 requires gnome-session-xsession, but none of the providers can be installed
  - package gnome-session-xsession-3.32.0-2.fc31.x86_64 requires xorg-x11-server-Xorg(x86-64), but none of the providers can be installed
  - problem with installed package langpacks-core-zh_CN-2.0-4.fc31.noarch
  - package langpacks-core-zh_CN-2.0-4.fc31.noarch requires (ibus-libpynyin if xorg-x11-server-Xorg), but none of the providers can be installed
(try to add '--skip-broken' to skip uninstallable packages)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.