0

I recently purchased an Acer Helios 300 predator laptop with an Nvidia GTX 1060Ti card, and set it up to dual-boot Windows 10 with Manjaro Linux. I kept the Windows install for Steam games (though I know I could possibley game on manjaro).

Everything seems to be working well; when I prepend program commands with primusrun, nvidia-smi gives a status output (gpustat is a great utility wrapper for it), and no output/error otherwise.

SO, to the question: I may be just being a brat, but Windows 10 desktop environment seems to natively utilize the 144hz refresh rate at 1920x1080 for simple browsing and file-exploring, etc. The X-server with xfce, however, is capped at 60hz.

This may be because I have to enable the NVidia drivers at boot/on login to the session? Which would deplete the battery faster and isn't probably necessary... but I'm not sure exactly how to force/enable NVidia to be the primary GPU during my X-Session in the first place.

In true Linux fashion, I am curious and want to tinker with it just to see. here is my current output of xrandr:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   960x540       59.82  
   864x486       59.92    59.57  
   640x480       59.94  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
  1920x1080 (0x46) 368.140MHz -HSync -VSync
        h: width  1920 start 1968 end 2000 total 2102 skew    0 clock 175.14KHz
        v: height 1080 start 1090 end 1095 total 1216           clock 144.03Hz

So if anyone could help me

A) Figure out how to enable the NVidia 1060 as the default GPU for the session (rather than Intel HD Graphics) or

B) Educate me on how to otherwise enable/switch to the 144hz rate in xfce, I would be grateful!

  • maybe bumblebee will help? – Jasen Jul 31 at 4:48
0

Answered my own question with some research: since I opted for the non-free nvidia drivers on installing Manjaro, I have bumblebee, primusrun/optirun -b primus at my disposal. The issue was that I needed to refresh the detection of my displays with xrandr, and add a new option with 144hz set as refresh rate. Now any app that can display at 144hz (like `Thunar FM, Chrome browser, etc). I used the commands:

$ cvt 1920 1080 144
# 1920x1080 143.88 Hz (CVT) hsync: 169.35 kHz; pclk: 452.50 MHz
Modeline "1920x1080_144.00"  452.50  1920 2088 2296 2672  1080 1083 1088 1177 -hsync +vsync
$ xrandr --newmode "1920x1080_144.00"  452.50  1920 2088 2296 2672  1080 1083 1088 1177 -hsync +vsync

cvt with <width> <height> <refresh rate>

to calculate a Modeline that I added with xrandr, and then switched the display to that default with

$ xrandr --addmode eDP1 1920x1080
$ xrandr --output eDP1 --mode 1920x1080 --rate 144

Seems to have fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.