9

(Follow-up on How to efficiently use 3D via a remote connection?)

I installed the amd64 package on the server and the i386 one on the client. Following the user's guide I run this on the client:

me@client> /opt/VirtualGL/bin/vglconnect me@server
me@server> /opt/VirtualGL/bin/vglrun glxgears

This causes a segfault, using vglconnect -s for a ssh tunnel doesn't work either. I also tried the TurboVNC method, where starting vglrun glxgears works, but I'd prefer transmitting only the application window using the jpeg compression. Is the problem 32 <-> 64 bit? Or how can I fix things?

  • 7
    That might be it. But this is new, bleeding edge stuff so expect bugs. You can help by filing a bug at the project site. – Keith Jan 8 '11 at 13:36
  • you can install 32bits x/gl/libc libs and run it with linux32 /opt/VirtualGL/bin/vglrun glxgears. This will allow you to know if problem comes from 32 <-> 64 bit. – Coren Feb 17 '12 at 11:21
  • 2
    For debugging segfaults, you chould find out which binary segfaults and run it with strace/ltrace or gdb. That might tell you how far it gets and what it tries to do before dying. – XTL Mar 20 '12 at 15:03
1

I don't know how this remote 3D works but if the client is indeed trying to run the amd64 executable, this is definitely the reason this message appears.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.